1 Star2 Stars3 Stars4 Stars5 Stars (5 votes, average: 4.60 out of 5)
Loading...

Update in: 17 February 2022


:

Pandora FMS WP is a monitoring plugin for WordPress. 100% free and OpenSource. It collect basic information from your WordPress and allow Pandora FMS to retrieve it remotely using a REST API. Some examples are new posts, comments or user logins in last hour. It also monitor if new plugins or themes has been installed, if a new user has been created or if a bruteforce login attempt has been made recently. You can expand easily by defining custom SQL queries to monitor other plugins or create your own SQL to collect information and sent it to Pandora FMS.

This plugin has been developed by Pandora FMS team. Sourcecode is available at https://github.com/articaST/pandorafms-wp/

Sections:

  • Dashboard: here, you can view a summary of the items monitored: plugins updated, version of WP and if they need an update, total users, new posts in last 24hr, new replies in 24hr and other checks.
  • Audit records: You can view a table with user access data: users, IP, if the login has been correct or incorrect and how many times, and the date of the last access. Also can see if new plugins or themes have been installed and the date on which these events occurred.
  • General Setup: Set general options:
    • API Settings
      • List of IPs with access to the API.
      • Set the time to show new data in the API.
    • Delete Logs Time
      • Clean fields of filesystem table with status deleted for data older than X days
      • Remove the status ¨new¨ on fields of filesystem table for data older than X days
    • Custom SQL queries

PREREQUISITES

  • PandoraFMS-WP requires (optionally) a plugin for REST API, called “JSON REST API”. Only needed if you want to integrate the monitoring/status information of the WP site into a central management console with Pandora FMS. This is an optional feature, you can manage all information from WordPress itself.
  • If your WordPress version is lower than 4.7, you must have the WP REST API (v2) plugin installed to use the API. (This plugin requires version 4.6 or higher).

LIMITATIONS

  • WP Multisite not supported on this version.
  • To use the WordPress API REST, you need version 4.6 or higher.

Additional URL

Official plugin website at WordPress.org: https://wordpress.org/plugins/pandora-fms-wp

(Visited 380 times, 1 visits today)

For correct visualization of the Pandora FMS library extension, you must have installed version NG 760 or superior

X