Project management
| Last modification: August 2026. | Version: 109 OUM |
Pandora ITSM allows dynamic project management including planning, tracking, and reports. In this way, it is possible to plan times (and costs) and also see the evolution of projects over time thanks to the time tracking of the people collaborating on the projects. This time tracking can be done in detail, in the form of Work units (Workunits) specifically assigned to each task (and task incidents, if there are any) of the project.
Pandora ITSM allows some automatic actions such as cost calculation, notifications about changes in tasks, and milestones. It also includes a Gantt chart that makes it easy to visualize the distribution of tasks over time.
Projects and tasks
Menu Projects → Projects list.
Tasks can have tickets associated with the incidents that arise or work units where you can track with a time breakdown of the work performed by each person.
New project
Menu Projects → Project list → Create project.
In this view, you can set a user in charge of the project (by default, the user who is creating the project), a project group, and an email address (CC field) which will be used to send notifications related to the project, among other data (start date, Project types, etc.).
It is also possible to replicate the tasks already created in another project.
If the option to replicate tasks is chosen, they will be configured with their original dates, so each of them must be reconfigured later.
As of version 106, and to facilitate the CRM process, a project can be associated with a company or contract as long as none of the tasks of said project is associated with a company or contract (and vice versa).
General project view
Project edition
Menu Projects → Project list, click on project name.
When entering project edition, by default it goes directly to the Project overview tab .
The section that can be edited in this view is Details. When you click on Quick edit, the main project fields such as project group, status template, and tag template can be changed.
The other sections present important information in a summarized way.
This project edition window has the following tabs:
Full edition of the project (exactly the same interface as project creation).
At the bottom, also:
Notes (version 106 or later).
- Members
where you can add or remove users globally to the project (list of available users for tasks and other works).
People management
Menu Projects → Project list → Project overview, Members section
at the end of the screen.
This section presents the people involved in the project and from which you can add new users with different roles (Add role people button) or manage existing ones (icon
in each person cell, just to the left of their role name in the project).
Within the projects, different tasks will be created in which people will participate. These people can participate both in the project globally and in the tasks themselves with a specific role in each case. Individually, at the task level, these roles can be readjusted.
Depending on their assigned role, the users participating in the projects and tasks will have different privileges, from full modification to simple work reporting.
Project view
Menu Projects → Project list → Project overview.
Statistics section with relevant data about the project:
Work distribution and Task distribution sections with percentage charts:
Project activity section:
Budget tab with the project's profitability percentage and other important values:
Project tracking tab:
Tasks
Menu Projects → View projects → Project overview, Task planning tab
In this view, the list of created tasks will appear and they can be sorted by each column. To do this, the column by which the list is sorted will present a black triangle icon pointing up or down (ascending or descending) in each column header.
In the Hours worked column , you can access a pop-up window with summarized information of the work units carried out in that task, such as cost, hours worked, etc., and with the option to filter by dates and/or milestones and/or people. In case of having incidents associated with the project and their comments (work units), you must filter by the full user identifier in Task people involved and start date. All this information, once filtered again, can be exported in CSV format and thus imported into a spreadsheet.
In the column called Op. you can:
- Check the Members icon
for the people participating in each task.
- Add an incident (ticket) in the Issues icon
. So that the cost of the work units (expressed as comments) are accounted to the task (and therefore to the project), a role must be assigned and the Add to project`s cost option checked in each of them at the time of creation. See also “Creation of new work units from the task planner”. - Permanently delete the task
.
To create a task, use the Create button located at the bottom of the task list.
New task
Menu Projects → View projects → Project overview, Task planning tab
, Create button located at the bottom of the task list.
Initially, a task is created with its basic data such as start and end dates (with the option to send email messages at those times to the people integrating the task), the task owner, and the estimated number of hours.
A useful option is to define if the task will be done recurrently in a period (weekly, monthly, etc.) to keep an hours counter that will restart at the end of each period, always keeping a total count of task hours.
Once created, the next logical step is to edit the task to assign resources (people) to it.
Task edition
After creating a task, it is immediately edited in order to assign resources (people, Add users to task section) and objective costs based on time, tags, as well as a criticality or priority for it.
From here, and based on the tracking of hours to said task made by the users assigned to it, it will be possible to know the time deviations, cost deviations, and planning deviations on the man-hour resources. Pandora ITSM automatically generates those indices that can be consulted in real time.
The task progress can also be carried out automatically according to the hours that people perform and are registered in work units; for this, the Progression based on hours token must be activated.
As of OUM version 108, if the Progression based on hours token is disabled, when manually modifying the progress bar the task status remains the same, without changing.
Finally, in the task links section (Tasks links), the rest of the tasks can be chronologically related to the task being edited:
- Start to start (Start to start): All tasks added in this section cannot start before the task being edited starts.
- Finish to start (Finish to start): All tasks added in this section cannot start before the task being edited finishes.
- Finish to finish (Finish to finish): All tasks added in this section cannot finish before the task being edited finishes, although it can finish later.
Roles and costs
Menu People → Roles management.
The roles to be used by different people can be created in this section. To edit each one, click on the role name in the list presented.
Upon installing Pandora ITSM, there are created roles which can be edited or deleted (the Project Manager role can only be edited). It is recommended to translate each line. When using the Reset all data option from the configuration in “Maintenance of old data”, these roles are kept.
- Project manager.
- Systems engineer.
- Junior consultant.
- Junior programmer.
- Senior programmer.
- Analyst.
- Senior consultant.
- Support engineer.
The costs of each task are calculated based on the costs of each role (man/hours) and the additional imputed costs (in the form of expense invoices, additional expenses, or any other formula) directly imputed to the task (and therefore to the project).
Task tracking
Pandora ITSM tracks (tracking) practically all those sections or information elements that are susceptible to changes. In the case of the task, it registers all opening, closing, changing, and adding information operations, whether in the form of a work unit or an attached file.
Move task
The Work Units of the task will remain linked to it even if it is moved from a project or parent task.
Creation of new work units from the task planner
The work units of a project can be created from the task planner by clicking the corresponding button
(recommended option) or from the user section, menu People → Work unit → Add work unit.
Through the manual creation of work units, time can be imputed into a project and task.
These manual work units are different from the tickets comments (also called work units).
- In the case of ticket work units, they will automatically impute the total time of the ticket when it is assigned to a task, has an assigned role, and the Add to project`s cost option is enabled.
- For these individual work units, which will be added manually by the user, time will be imputed directly according to what is entered when creating the work unit. The creation form has a series of basic fields (description, number of hours spent on the work unit, cost, role, etc.).
It also offers controls that allow you to “split” the work unit into blocks of x amount of hours (by default 4) and distribute that time in different Work Units (WU) over time (forwards or backwards, as chosen) with the same content as the original one, except for the date.
There are two special cases contemplated by Pandora ITSM:
- Telecommuting (Work from home).
- Work units without assigned project/task.
These concepts correspond to special tasks within a special project that are computed differently.
There is also a special section (menu People → Work unit → Vacations and sick leave) to cover cases of absence due to illness or medical assistance and vacations.
Custom fields in project tasks
Menu Projects → Task types → Create.
As of version 108, the powerful functionality of custom task fields is available, which allows you to add additional information in a classified way (numeric, text, dates, etc.). Then all this information can be filtered and used for administrative and/or organizational purposes.
With slight differences, the complete operation is similar to the custom ticket fields.
First, you must create at least one task type and then add the custom fields that are necessary:
Then when editing a project task, select the task type and its custom fields will appear:
Milestones
Menu Projects → Project list→ Project overview, Milestones tab
A milestone is a zero-duration task that represents an important date or specific moment in a project, such as the completion of a project phase, or the delivery date of a particular report. Milestones can be used to filter information in reports or in searches related to a project.
Milestones support the creation of custom fields with the Milestone fields button. When creating each custom field, you can define:
- Name: It is mandatory, names can be repeated.
- Field visibility: To display custom fields in the milestones list.
- Type:
- Text: Single-line text type.
- Text area: Multi-line text type.
- Combo: To show a list of options to choose from, their elements must be separated by commas.
- Checkbox: To select true and false values.
Attached files
Menu Projects → View projects → Project overview, Attachments section
Attached files to a project can be uploaded, downloaded, or deleted. Optionally, a description can be added, which is useful for keyword searches. The search can also be performed by location (project, incidents, or work units) of the files and/or by storage date.
Files with source code format (.php, .pl, etc.) cannot be uploaded, and it is recommended to compress the files before uploading them.
Attached files can only be deleted by an administrator user or by the user who created the attached file and has administration permissions in projects.
Gantt chart
Menu Projects → View projects → Project overview, Gantt chart tab
.
This utility allows visualizing, even in full screen, all the project tasks as well as their chronological relationship as a series of steps: Upon completing a task, it links to the next one. It also allows adding new tasks (or subtasks by clicking on + for each task), related or not. Relationships are configured by clicking on the end of a task (circle icon) and then dragging to the beginning of its corresponding next task.
Existing tasks can be modified in their start and end dates as long as they are not related to other tasks. For mutually related tasks, there is a limitation between the end of one task and the start of the next one.
You can choose the real view (Show real planning list) to compare the planning with the tasks performed, whether monthly, weekly, or daily.
Archiving and deleting projects
Menu Projects → Project list, Options column.
At the end of the projects, they can be moved to an archived status, saving all the information they contain.
An archived project can later be deleted, thus disappearing all its tasks. The work units it contains become “orphaned” and will not be assigned to any project or task, although they will continue to exist.
To archive a project, use the archive button of each project: menu Projects → Project list → Options → Archive . That project will automatically move to the archived projects view. Such projects do not automatically notify the closure of tasks, projects, or milestone(s).
To view both active and inactive projects, you must click the Filters button, in Active select Any and then click on Apply filters. Every time the list is refreshed, the default filter values will be loaded.
Archived projects can be activated again from the projects view: menu Projects → Project list → Options → Unarchive or, on the contrary, permanently delete them with the Delete action
.
Board view
Menu Projects → View projects → Click on project → Board view.
Version 105 or later.
Board view allows visually managing the tickets and tasks belonging to a project.
It is important to note that there is a horizontal scroll bar at the bottom of the screen, this to be able to show all the columns (status) that a project has.
The central mechanism of the Board view is the filter section, which allows organizing the task information in columns:
Selecting the involved users and/or percentage of completed task and/or tags assigned to the tasks, among other values, you can filter by clicking the Apply filters button.
Each column can be collapsed or expanded as needed, and within each of them, the filtered tasks will have their own quick options for editing, creating Work units, moving the task, copying it, deleting it (or even leaving the Board view to edit the task on a new screen):
In turn, and by default, each task will appear collapsed with its own button to expand or collapse:
In each column you can select all the tasks (or by pressing the CTRL key and clicking on each task to select or exclude from the selection) to later be able to massively move to another column:
With all these options, you can supervise and/or reorganize an entire project in a short time: set dates, create new tasks and assign them, postpone or advance work, etc.
Task statuses
Only version 105 OUM.
Menu Project → Task status.
In version 105, there were four statuses created by default and they could only be modified by users with PM permission or superadmin.
See the following section.
Menu Project → Task status templates.
Version 106 OUM or later.
All projects keep their configured statuses, which are now in the default status template, system-wide. Templates can be created for each project in order to have custom statuses for each particular project.
The default template, as well as its four default statuses, cannot be deleted. If a status template is created, these four statuses will be copied (with the assigned color they have at the time) and will also be undeletable. If the new status template is deleted and was being used by a project, that project will start using the default status template.
It should be noted that when changing a project to another status template, the status will be deleted and the appropriate status of the new template must be placed.
Export to CSV
When exporting to CSV, projects are included, without statuses, tasks, or tickets.
The file to download contains the following headers in its first line:
ID, Project, Parent Task, Task name, Description, Completion, Work units hours, Status, Priority, Start, End, Estimated hours, Cost, Periodicity, Start period, Interval hours, CC, Send email, Set hours, Involved people, Tags
If you connect via HTTPS to the Web Console, the download will be automatic; if HTTP is used, it may be necessary to enable an exception in the web browser to keep the download.
Custom tags for project tasks
Only version 105 OUM.
Menu Projects → Project tags.
Only in this version is the global use of shared tags in project tasks available. Three tags (Low, Medium, High) were included by default and could be modified at convenience (or even deleted).
See next section.
Menu Projects → Task tag templates.
Version 106 OUM or later.
As of this version, projects keep their inherited tags, which belong to the new default tag template. In this way, more templates can be created, even one for each project, so they stop being global (unless it is decided to keep only the new default template).
For each template created, its own custom tags must be added.
Each project has the option to use any of the different available tag templates with the exception that every time the template is changed, the tags added to the tasks will be deleted.
Project notes
Version 106 OUM or later.
This option allows saving messages for internal use, as a logbook.
Then searches can be filtered using keywords. This is the only way to access since these notes are excluded from the system reports.
Project notes cannot be edited or deleted. Since version 107, each note can be associated with a project task (by default it does not associate them). All notes will be displayed unless they are filtered task by task.
Workflow rules
Menu Projects → Workflow rules.
These rules work independently of the ticket workflow rules.
By default, when installing Pandora ITSM, four rules are inserted which come disabled. Each rule can be applied at the project level and/or tasks that belong to it through a series of conditions.
In the rule list, the execution mode stands out, Cron to be applied periodically by the operating system hosting the PITSM Server or Real time when users trigger events while performing their work with each project.
- To create a new workflow rule in projects (or edit one of them
), you must click the Create a workflow + button and optionally place a name, otherwise, when saving using the Create button, it will be automatically numbered consecutively.
- The next step is to go to the Conditions tab
and click the Create button to establish the fields and the conditions to be met (project and/or project tasks).
Important: Clicking Create again will save the changes regardless of whether a description and/or any condition was set.
- Once the necessary conditions have been created, they can be related to each other with logical operators (by default
OR, which allows executing the actions if one rule or another is met):
- The checking order can also be established; some frequent or highly necessary conditions will be placed at the beginning of the checklist using the Up or Down buttons in the Action column and according to each case.
The last step is the Actions tab to add the action or actions of sending an email message to a user or users, changing the project manager, etc., when all the conditions of a rule have been met.
Macros
In the Email template configuration, the following macros can be used to insert:
| Macro name | Description |
|---|---|
_next_milestone_ | Date and time of the next milestone. |
_project_completion_ | Percentage of work completed in the project. |
_project_cost_deviation_ | Cost deviation of the project. |
_project_costs_ | Project cost. |
_project_end_date_ | Project end date. |
_project_estimated_costs_ | Estimated project cost. |
_project_estimated_hours_ | Estimated amount of project hours. |
_project_manager_ | Project manager. |
_project_name_ | Project name. |
_project_pending_hours_ | Amount of hours left to work on the project. |
_project_start_date_ | Project start date. |
_project_used_hours_ | Amount of hours worked on the project. |
_project_users_ | Users involved in the project. |
_task_completion_ | Percentage of work completed in the task. |
_task_end_date_ | Task end date. |
_task_estimated_hours_ | Estimated amount of task hours. |
_task_name_ | Task name. |
_task_pending_hours_ | Amount of hours left to work on the task. |
_task_recurrence_ | Task periodicity. |
_task_start_date_ | Task start date. |
_task_used_hours_ | Amount of hours worked on the task. |
_task_users_ | Users involved in the task. |
_workflow_content_ | A summary of task hours, periodicity, etc. |
Reports and views
The available project reports are described generally; for their advanced options see “Project reports”.
Each of these reports has the option to view in full screen and export in CSV and PDF formats (except “Project bundle of hours report” which can only be exported in PDF).
General project report
Menu Reports → Project management → General project report → Select project.
Selecting a project immediately shows its corresponding view.
This view includes the basic data, total people and hours worked, total budget and broken down by role with average hourly cost, in a graph the percentage distribution of tasks and in another graph the distribution of work among the participating people. Finally, it shows the activity graph and a summary of each of the tasks.
- By enabling Show task activity, you must select one or more tasks and at the end it will show the activity of each task, in addition to the hours worked, cost, and distribution of work to the people assigned to each task.
- By selecting Show task work unit and in the selected tasks, the work units performed for each task will be shown in detail.
Finally, by enabling Show in table, all tasks will be displayed in tabular form with the owners, priority, involved people, and task status.
All projects report
Menu Reports → Project management → All projects report.
By default, it shows projects from the last year (a different date can be specified) as well as archived projects optionally.
Projects without a start or end date will be queried with the date 0000-00-00. If the project types have custom fields, it will also be possible to filter by this criterion, always taking into account the project start date.
Project expense report
Menu Reports → Project management → Project expense report.
By default, it shows the projects from the last month with the option to show the amounts of each task with the Show task breakdown option.
When selecting a specific project, you can filter by milestones range.
Project bundle of hours report
Menu Reports → Project management → Project bundle of hours report.
Allows selecting a specific project and month. It shows the basic information of the project, summarized information of the completed tasks and related incidents. It ends with the totalization of consumed hours and remaining hours.
Project groups
Menu Projects → Projects groups.
Pandora ITSM allows logical grouping of projects using this option in order to organize or classify projects that share development characteristics.
A name must be entered, which can be repeated, and optionally an icon to distinguish it from other project groups.
After creating a project group, you must go to each of the projects to be grouped and add them to the created group. In this way, in the project list view, you can filter by project groups.
Project types
Menu Projects → Projects types.
With this functionality, Pandora ITSM allows project distinction. This is useful when having a large number of projects and making quick searches in the project list.
You can access the editing of the custom fields of each project type using the Actions → Add field option.
Unlike Project groups, the following custom fields can be added to project types:
- Text type (single-line and multi-line).
- True and false option.
- Numeric type.
- Date type.
- List type (Combo).
- Lists with hierarchically related options.
- URL type accompanied by a description of it.
These custom field values can also be filtered by exact values in the project list.
Custom fields share three common characteristics:
- Show in the projects list: When activating this option, said custom field will be shown as a column in the project list.
- Global field: When activating this option, the custom field will be added to existing project types and also to future ones to be created.
- Required: If this option is activated, it will always be required to set or choose a value in order to save the changes.
- If a custom field is marked as Global field at the time it is created, it can later only be deleted, with no editing possible.
- If a custom field is marked as Global field with Show in the projects list activated at the time it is created, as many columns will be shown as there are project types created.
- To edit a project, you must click on the
icon for each corresponding project and subsequently you can choose the project type (and its custom fields) for each project.
- By default, projects are created without belonging to any project type (this also happens when a project type used by a project is deleted). Thus, special care must be taken when editing a project because the first one in the project types list will be automatically selected and saved that way.






















