Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Ubuntu packages with invalid schema
#1
Hello, I'm trying to install Pandora  console for the first time and I'm experiencing errors with the package in the Ubuntu distro.
It appears that the package contains an invalid schema with regards to the MySql 5.7 and NOT NULL defaults as I can't manually create the schema with pandoradb.sql either.
Advise?
 Reply
#2
(02-04-2019, 05:54 PM)dbarronoss Wrote: Hello, I'm trying to install Pandora  console for the first time and I'm experiencing errors with the package in the Ubuntu distro.
It appears that the package contains an invalid schema with regards to the MySql 5.7 and NOT NULL defaults as I can't manually create the schema with pandoradb.sql either.
Advise?

Good morning dbarronoss,

Actually Pandora FMS works with MySQL 5.5, the problem can be that you have a higher version, so Pandora FMS cannot be installed because of that fact.

Please try to install the MySQL 5.5 and install it again.

Alberto
 Reply
#3
Hello dbarronoss,

Hope the answer of alberto.sanchez helps you to solve your problem.

Please, do take a few minutes to write a Pandora FMS review in order to help us continue monitoring systems... https://bit.ly/2S9Y2kp

Thank you for your time!

Regards
 Reply
#4
(02-05-2019, 10:35 AM)jose.almendros Wrote: Hello dbarronoss,

Hope the answer of alberto.sanchez helps you to solve your problem.

Please, do take a few minutes to write a Pandora FMS review in order to help us continue monitoring systems... https://bit.ly/2S9Y2kp

Thank you for your time!

Regards

I'll give it a shot, assuming I can still find/install that old a MySQL.  I had saw on the forum where someone had installed with 5.7 so I tried that.  I would normally be using an 8.* version.  Maybe the installer should check the version of mysql installed?
No, 5.7 is the oldest mysql in the Ubuntu repository.  Guess Pandora shall not be for me.
 Reply
#5
(02-05-2019, 11:09 AM)dbarronoss Wrote:
(02-05-2019, 10:35 AM)jose.almendros Wrote: Hello dbarronoss,

Hope the answer of alberto.sanchez helps you to solve your problem.

Please, do take a few minutes to write a Pandora FMS review in order to help us continue monitoring systems... https://bit.ly/2S9Y2kp

Thank you for your time!

Regards

I'll give it a shot, assuming I can still find/install that old a MySQL.  I had saw on the forum where someone had installed with 5.7 so I tried that.  I would normally be using an 8.* version.  Maybe the installer should check the version of mysql installed?
No, 5.7 is the oldest mysql in the Ubuntu repository.  Guess Pandora shall not be for me.

Hello dbarronoss,

To install MySQL 5.5 you can follow this tutorial: https://gist.github.com/ahmadhasankhan/4...751a56884b

With this MySQL version: https://dev.mysql.com/downloads/mysql/5....#downloads

I tested recently that version in Ubuntu 18.04 and works without problem.

Regards.
 Reply
#6
Thank you for your assistance, but i have other software using mysql on that host and don't want to regress.
 Reply
#7
(02-05-2019, 12:39 PM)dbarronoss Wrote: Thank you for your assistance, but i have other software using mysql on that host and don't want to regress.

Good morning dbarronoss,

Sorry for this inconvenience with Pandora FMS. In a future we are looking to upgrade MySQL to latest version, hope this would help you in order to try Pandora FMS.

Alberto
 Reply
#8
In Ubuntu I don't know, but in CentOS works perfectly with MySQL 5.7.

I always install MySQL with binaries, not with repos and works perfectly, try to install with binaries or use CentOS: DDD
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes