Welcome to Pandora FMS Community!

Find answers, ask questions, and connect with our community around the world.

Welcome to Pandora FMS Community Forums Soporte de la comunidad No inician los modulos wmi

  • No inician los modulos wmi

    Posted by Infra on March 25, 2024 at 20:08

    Buen tardes comunidad

    En este caso quiero consultar sobre la creacion de los modulos wmi. Tengo activado el wmi server y pandora wmic funciona pero cuando creo cualquier modulo ya sea de forma manual o con el wizard me aparece en modulo no iniciado. Espero un rato y sigue igual. Cual puede ser el problema? Tengo pandora fms opensource version 72.1

    Infra replied 2 days, 23 hours ago 3 Members · 11 Replies
  • 11 Replies
  • vic

    Administrator
    March 25, 2024 at 21:05
    1288 Karma points
    Community awards: bulb Bright ideas
    Community rank: tentacle_master_icon Tentacle Master
    Like it
    Up
    0
    Down
    Drop it
    ::

    Buenas tardes Infra,

    Si tiene la versión 721, le recomiendo actualizar ya que en el 2020 hubo un problema con una dependencia que quedó obsoleta y que impedía que se inicializasen.

    Pruebe a actualizar a una versión más reciente para solucionar dicho problema y solucionar problemas de vulnerabilidades u otros bugs en la herramienta.

    Recuerde que tendrá que actualizar varias dependencias, como PHP, MySQL, y otras cuantas más, etc…

    Un saludo,
    Víc.

  • Sergio

    Administrator
    April 8, 2024 at 15:17
    881 Karma points
    Community rank: tentacle_master_icon Tentacle Master
    Like it
    Up
    0
    Down
    Drop it
    ::

    Buenos días Infra,

    Hemos creado ambos WMI en consola y vemos que inicializa correctamente con la siguiente configuración:

    Revisa las capturas y comprueba que tienes exactamente la misma configuración, principalmente que el dato que espera el módulo sea correspondiente con el tipo de dato que envia la consulta WMI, en el caso del nombre del DNS Host Name deberá ser de tipo generic_data_string y en el caso de los procesos deberá ser generic_data

    Si los módulos no tienen este tipo de dato esperado, habría que crearlos nuevamente ya que una vez creado el módulo no se puede cambiar el tipo de dato, hay que borrar el módulo y crearlo nuevamente.

    Un saludo,

    Sergio B.

  • Infra

    Member
    April 8, 2024 at 17:41
    94 Karma points
    Community rank: tentacle-noob-1 Tentacle noob
    Like it
    Up
    0
    Down
    Drop it
    ::

    Realice la configuracion como la que me pasaste y el modulo sigue en sin inicializar