Welcome to Pandora FMS Community!

Find answers, ask questions, and connect with our community around the world.

Welcome to Pandora FMS Community Forums Community support Reporting – Export to XML

  • Reporting – Export to XML

    Posted by linspec9078 on January 18, 2024 at 15:31

    Hi team,

    we are on 772.2.

    I noticed that when I try to export a report in XML format, base64 encoded data is empty:

    <chart>&lt;img src=”data:image/png;base64,” /&gt;</chart>

    In the past chart data was there.

    Is this an expected behaviour ?

    Thank you.

    linspec9078 replied 1 month, 1 week ago 2 Members · 3 Replies
  • 3 Replies
  • Sergio

    Administrator
    January 18, 2024 at 16:39
    782 Karma points
    Community rank: tentacle-noob-1 Tentacle noob
    Like it
    Up
    0
    Down
    Drop it
    ::

    Hello,

    Thank you for the feedback provided.

    It seems that it has been bugged in the latest release.

    We have opened a ticket with our development team in order to fix this issue in the upcoming release v776.

    We’ll let you know once we release the new version.

    Kind regards,

    Sergio B.

    • This reply was modified 1 month, 1 week ago by  Sergio.
  • Sergio

    Administrator
    January 19, 2024 at 11:09
    782 Karma points
    Community rank: tentacle-noob-1 Tentacle noob
    Like it
    Up
    0
    Down
    Drop it
    ::

    Hello,

    We are going to need you to tell us exactly which type of report are you extracting in order to replicate the issue.

    Can you please post here some screenshots of the report, items, that generates this bug?

    Thanks in advance.

    Kind regards,

    Sergio B.

  • linspec9078

    Member
    January 19, 2024 at 11:20
    292 Karma points
    Community rank: tentacle-rookie Tentacle rookie
    Like it
    Up
    0
    Down
    Drop it
    ::

    Hi,

    report is built only with “Simple Graph” items.


    Other settings are:

    Timelapse : 1 month 1 day

    Graph render: Avg only

    If view the report from the GUI i see all the graphs.

    But while exporting to xml the chart tag is empty.


    I observ the issue also in 772.1 .


    Best regards.