Welcome to Pandora FMS Community!

Find answers, ask questions, and connect with our community around the world.

Welcome to Pandora FMS Community Forums Community support Advanced troubleshooting Como borrar definitivamente un module de un agente creado en modo “Asynchronous”

  • Como borrar definitivamente un module de un agente creado en modo “Asynchronous”

    Posted by rischfre on August 4, 2022 at 16:16

    Hola

    en un fichero de configuración Pandora_agent.conf, he definido un modulo de tipo. <strong style=”font-size: inherit; color: var(–bb-body-text-color);”>Asynchronous”.

    Después de usarlo, he decidido quitarlo completamente (borrar module, historial, …).

    Para lograr esto: he borrado la parte del modulo en Pandora_agent (y reiniciar el servicio), y borrado el mismo modulo en la consola.

    Pero a la sincronización siguiente (5min) vuelve a aparecer, incluso con valores históricas

    Cual es la manera correcta de quitar un modulo?

    rischfre replied 1 week, 3 days ago 2 Members · 2 Replies
  • 2 Replies
  • Sergio

    Administrator
    August 5, 2022 at 10:14
    20 Karma points
    Community rank: Tentacle noob
    Like it
    Up
    0
    Down
    Drop it
    ::

    Hola.

    Si tiene una versión de pandora inferior a la 734, le recomendamos actualizarla.

    Revise que el módulo no existe ni a nivel local (pandora_agent.conf) ni en consola.

    De todas maneras, debe fijarse si tiene la opción xml_buffer habilitada en el fichero de configuración del agente, y si es así debe deshabilitarlo y eliminar los xml generados en el directorio /tmp(linux) o C:\Program Files\pandora_agent\temp(windows).

    Recuerde si tiene la configuración remota habilitada, si es así, debe cambiar el fichero pandora_agent.conf a través de consola.

    Esperamos su respuesta.

    Un saludo.

    Sergio Portalo

  • rischfre

    Member
    August 5, 2022 at 16:47
    70 Karma points
    Community rank: Tentacle noob
    Like it
    Up
    0
    Down
    Drop it
    ::

    Gracias Sergio,

    estoy en 2 linux (agente y servidor), los 2 con version recientes (758 y 762), sin configuracion remota del agente

    He hecho los cambios que me has dicho y funcciona.

    1. Parar el Agente

    2. modificar la variable xml_buffer 0

    3. borrar los modules del agente

    4. borrar los modulos de la consola

    5. iniciar el Agente

    6. volver a parar el agente

    7. cambiar el xml_buffer a 1

    8. reiniciar el Agente

    –> todo esto porque no he encontrado los xml que me comentabas en el /tmp

    donde se define el “path” para estos ficheros?