Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with WMI modules after restart
#1
Hi!
I'm new with pandora fms 7 community edition and I'm having a issue that I can't find the way to fix it.

The problem is with WMI modules. They works fine at first. But if I reboot the machine (or even restart the pandora_server) then I lose contact with the already created modules and can't initialize new ones.
Other modules types works fine.

If I execute the WQL query (the same one that the log prints) directly from the server console (with wmci), it works fine.

I've looked and compared the logs but I can't find any clue.

I've installed the appliance cd image on a vmware vm.

Could you help me please?

Thank you in advance Wink
 Reply
#2
Hi alealt,

Can you say me the complete version of Pandora server and the version of Pandora console?

Best regards,

vic.
 Reply
#3
(08-10-2017, 02:28 PM)vic Wrote: Hi alealt,

Can you say me the complete version of Pandora server and the version of Pandora console?

Best regards,

vic.

Hi Vic,

From pandora_diag
Code:
Elemento    valor de los datos
Pandora FMS Build    PC170728
Pandora FMS Version    v7.0NG.709
Homedir    /var/www/html/pandora_console
HomeUrl    http://192.168.2.234/pandora_console/
PHP Version    5.4.16
DB Table tagente    8
DB Table tagent_access    514
DB Table tagente_datos    4821
DB Table tagente_datos_string    0
DB Table tagente_estado    42
DB Table tagente_modulo    42
DB Table talert_actions    5
DB Table talert_commands    12
DB Table talert_template_modules    2
DB Table tevento    108
DB Table tlayout    0
DB Table tserver    5
DB Table treport    0
DB Table ttrap    0
DB Table tusuario    2
DB Table tsesion    70
DB Schema Version (first installed)    6.0dev
DB Schema Version (actual)    6.0RC1
DB Schema Build    PD150908
Enterprise installed    
PandoraDB Last run    2017/08/10 11:01:01
Update Key    PANDORA-FREE
Updating code path    Path where the updated code is stored
Current Update #    412

From server Log:
Code:
Launching 7.0NG.709 170728
 Reply
#4
Hi vic!

I got it working.
I'm not sure what is the problem but I found a workaround to solve the issue.

After reboot (or even systemctl restart pandora_server) all WMI modules goes to unknow status. Also if new WMI modules were added, they go stucked in no initialize status.
I have tried restart pandora_server through systemctl command without notice any change. Anyway the service was running before restart.
Today I've tried directly /etc/init.d/pandora_server restart and it's working.
Of course, if I reboot the system, i have to restart the service this way to get it working again, but it's ok for me.

Maybe there is something different when the service is launched by systemd. It's weird.

Regards.
 Reply
#5
Hi alealt,

We always recommended use the command "/etc/init.d/service" to restart the services.
Thanks for reporting!

Best regards,

vic.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2017 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes