Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Todos los sistemas caído(s)
#1
Buenas,

Estamos haciendo un proyecto de final de curso sobre PandoraFMS, tenemos un server montado con la ISO que proporcionáis de PandoraFMS junto a CentOS 7; tuvimos hace unos días un problema con los agentes ya que de repente dejó de detectarlos, estuvimos mirando el foro en busca de respuestas y vimos que había gente que actualizando la versión se le solucionaba; ya que nuestros agentes eran la versión 7.0NG 734 y nuestro server la versión 7.0NG 733 decidimos probar en actualizarlo, para evitar problemas lo probamos primero en una máquina virtual con la misma configuración que la original y todo fue bien.

Ahora de repente no para de salirnos el aviso de que todos los sistemas están caídos, hemos ejecutado todos los sservicios manualmente y hemos comprobado el estado y supuestamente están activos, pero nada, en la consola sigue saliendo que están caidos y no cambia aunque actualicemos, y tampoco nos detecta los agentes ni nada.

Hemos comprobado el log y nos sale un error de perl, comprobamos el perl CPAN e hicimos un cpan Encode y nada.

¿Podríais ayudarnos? Estaríamos muy agradecidos.

Atentamente,
Natalia Francisco
 Reply
#2
Buenos días natalia.francisco,

¿Habéis apuntado la máquina virtual al servidor principal en algún momento, o ha cambiado el nombre del servidor principal?

Si la base de datos principal ha detectado dos servidores en algún momento, y se ha apagado uno, los errores que están apareciendo pueden tratarse de este aviso.

Mándanos por favor un pantallazo de la ventana de Servers > Manage Servers y vemos en qué estado se muestran en consola.

Un saludo.
 Reply
#3
(05-10-2019, 08:12 AM)jose.almendros Wrote: Buenos días natalia.francisco,

¿Habéis apuntado la máquina virtual al servidor principal en algún momento, o ha cambiado el nombre del servidor principal?

Si la base de datos principal ha detectado dos servidores en algún momento, y se ha apagado uno, los errores que están apareciendo pueden tratarse de este aviso.

Mándanos por favor un pantallazo de la ventana de Servers > Manage Servers y vemos en qué estado se muestran en consola.

Un saludo.

Nosotros estamos en una red (hemos configurado incluso un router con OpenWrt) y las máquinas virtuales están en otra red diferente, así que no se pueden hacer ping entre ellas.
Te adjunto la captura tal y como me has pedido.

Muchas gracias por tu ayuda


Attached Files


.png   Captura de pantalla de 2019-05-10 17-34-47.png (Size: 135.8 KB / Downloads: 13)
 Reply
#4
(05-10-2019, 03:29 PM)natalia.francisco Wrote:
(05-10-2019, 08:12 AM)jose.almendros Wrote: Buenos días natalia.francisco,

¿Habéis apuntado la máquina virtual al servidor principal en algún momento, o ha cambiado el nombre del servidor principal?

Si la base de datos principal ha detectado dos servidores en algún momento, y se ha apagado uno, los errores que están apareciendo pueden tratarse de este aviso.

Mándanos por favor un pantallazo de la ventana de Servers > Manage Servers y vemos en qué estado se muestran en consola.

Un saludo.

Nosotros estamos en una red (hemos configurado incluso un router con OpenWrt) y las máquinas virtuales están en otra red diferente, así que no se pueden hacer ping entre ellas.
Te adjunto la captura tal y como me has pedido.

Muchas gracias por tu ayuda

Buenos días, natalia.francisco

¿Podrías por favor indicarnos el MR que tienes en tu instalación? Para comprobar el MR, accede a la base de datos y ejecuta la siguiente consulta: 

Code:
select * from tconfig where token like 'MR';


Como información adicional, ¿podríais decirnos cuántos agentes estáis monitorizando así como enviarnos los logs para estudiar los errores?

Un cordial saludo, 

Eduardo.
 Reply
#5
(05-13-2019, 10:38 AM)eduardo.corral Wrote:
(05-10-2019, 03:29 PM)natalia.francisco Wrote:
(05-10-2019, 08:12 AM)jose.almendros Wrote: Buenos días natalia.francisco,

¿Habéis apuntado la máquina virtual al servidor principal en algún momento, o ha cambiado el nombre del servidor principal?

Si la base de datos principal ha detectado dos servidores en algún momento, y se ha apagado uno, los errores que están apareciendo pueden tratarse de este aviso.

Mándanos por favor un pantallazo de la ventana de Servers > Manage Servers y vemos en qué estado se muestran en consola.

Un saludo.

Nosotros estamos en una red (hemos configurado incluso un router con OpenWrt) y las máquinas virtuales están en otra red diferente, así que no se pueden hacer ping entre ellas.
Te adjunto la captura tal y como me has pedido.

Muchas gracias por tu ayuda

Buenos días, natalia.francisco

¿Podrías por favor indicarnos el MR que tienes en tu instalación? Para comprobar el MR, accede a la base de datos y ejecuta la siguiente consulta: 

Code:
select * from tconfig where token like 'MR';


Como información adicional, ¿podríais decirnos cuántos agentes estáis monitorizando así como enviarnos los logs para estudiar los errores?

Un cordial saludo, 

Eduardo.
De MR tenemos la 27.

De agentes tenemos 2 torres, 1 portátil y el router, sin contar el propio server de pandora.


Attached Files


.png   Captura de pantalla de 2019-05-13 17-46-21.png (Size: 97.9 KB / Downloads: 5)
.png   Captura de pantalla de 2019-05-13 17-45-01.png (Size: 57.49 KB / Downloads: 4)
 Reply
#6
(05-13-2019, 03:38 PM)natalia.francisco Wrote:
(05-13-2019, 10:38 AM)eduardo.corral Wrote:
(05-10-2019, 03:29 PM)natalia.francisco Wrote:
(05-10-2019, 08:12 AM)jose.almendros Wrote: Buenos días natalia.francisco,

¿Habéis apuntado la máquina virtual al servidor principal en algún momento, o ha cambiado el nombre del servidor principal?

Si la base de datos principal ha detectado dos servidores en algún momento, y se ha apagado uno, los errores que están apareciendo pueden tratarse de este aviso.

Mándanos por favor un pantallazo de la ventana de Servers > Manage Servers y vemos en qué estado se muestran en consola.

Un saludo.

Nosotros estamos en una red (hemos configurado incluso un router con OpenWrt) y las máquinas virtuales están en otra red diferente, así que no se pueden hacer ping entre ellas.
Te adjunto la captura tal y como me has pedido.

Muchas gracias por tu ayuda

Buenos días, natalia.francisco

¿Podrías por favor indicarnos el MR que tienes en tu instalación? Para comprobar el MR, accede a la base de datos y ejecuta la siguiente consulta: 

Code:
select * from tconfig where token like 'MR';


Como información adicional, ¿podríais decirnos cuántos agentes estáis monitorizando así como enviarnos los logs para estudiar los errores?

Un cordial saludo, 

Eduardo.
De MR tenemos la 27.

De agentes tenemos 2 torres, 1 portátil y el router, sin contar el propio server de pandora.

Buenos días, Natalia

Nos ayudaría enormemente disponer de los logs para poder profundizar más en la causa de los fallos, ¿sería posible que nos los enviaseis?

Comprobad si podéis si el servicio Tentacle está funcionando correctamente y que el puerto que utiliza (41121 por defecto) está abierto. 

Una última pregunta: de cara a la actualización del servidor que teníais con la versión 733, ¿cómo hicisteis el proceso? ¿Fue mediante ISO o actualizando por paquetes? 

Un cordial saludo, 

Eduardo.
 Reply
#7
(05-14-2019, 08:33 AM)eduardo.corral Wrote:
(05-13-2019, 03:38 PM)natalia.francisco Wrote:
(05-13-2019, 10:38 AM)eduardo.corral Wrote:
(05-10-2019, 03:29 PM)natalia.francisco Wrote:
(05-10-2019, 08:12 AM)jose.almendros Wrote: Buenos días natalia.francisco,

¿Habéis apuntado la máquina virtual al servidor principal en algún momento, o ha cambiado el nombre del servidor principal?

Si la base de datos principal ha detectado dos servidores en algún momento, y se ha apagado uno, los errores que están apareciendo pueden tratarse de este aviso.

Mándanos por favor un pantallazo de la ventana de Servers > Manage Servers y vemos en qué estado se muestran en consola.

Un saludo.

Nosotros estamos en una red (hemos configurado incluso un router con OpenWrt) y las máquinas virtuales están en otra red diferente, así que no se pueden hacer ping entre ellas.
Te adjunto la captura tal y como me has pedido.

Muchas gracias por tu ayuda

Buenos días, natalia.francisco

¿Podrías por favor indicarnos el MR que tienes en tu instalación? Para comprobar el MR, accede a la base de datos y ejecuta la siguiente consulta: 

Code:
select * from tconfig where token like 'MR';


Como información adicional, ¿podríais decirnos cuántos agentes estáis monitorizando así como enviarnos los logs para estudiar los errores?

Un cordial saludo, 

Eduardo.
De MR tenemos la 27.

De agentes tenemos 2 torres, 1 portátil y el router, sin contar el propio server de pandora.

Buenos días, Natalia

Nos ayudaría enormemente disponer de los logs para poder profundizar más en la causa de los fallos, ¿sería posible que nos los enviaseis?

Comprobad si podéis si el servicio Tentacle está funcionando correctamente y que el puerto que utiliza (41121 por defecto) está abierto. 

Una última pregunta: de cara a la actualización del servidor que teníais con la versión 733, ¿cómo hicisteis el proceso? ¿Fue mediante ISO o actualizando por paquetes? 

Un cordial saludo, 

Eduardo.

Lo hicimos por paquetes, igualmente, hemos optado al final por reinstalar CentOS 7 de cero con la ISO original y luego a parte instalar los paquetes de Pandora manualmente, ya nos funciona todo.
Merci por la ayuda
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes