Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error en los comandos cuando incluyen signos como " -
#1
Buenas,

El error es el siguiente, cuando creo un comando desde el apartado "Comandos" para lanzar alertas de telegram utilizo las comillas, guiones, como vemos a continuación:

bin/telegram-cli –W –e “msg Alertas_Pandora_FMS _field1_” –k /usr/local/src/telegram/tg/tg-server.pub

Ese comando si lo lanzo desde la línea de comandos cambiando el _field1_ por el texto que quiera lo envía sin ningún problema.

El problema viene que al pasar a la pestaña "Acciones" del Pandora FMS los símbolos han cambiado. Me aparece lo siguiente:

bin/telegram-cli –W –e “msg Alertas_Pandora_FMS Caida del dispositivo” –k /usr/local/src/telegram/tg/tg-server.pub

Parece que cambia los símbolos por lenguaje HTML  y de esta manera el comando no funciona. Necesita ayuda!

Gracias a todos!


Attached Files


.png   2019-04-01_1111.png (Size: 20.63 KB / Downloads: 5)
.png   2019-04-01_1111_001.png (Size: 44.4 KB / Downloads: 3)
 Reply
#2
(04-01-2019, 09:12 AM)franciscoquintanilla Wrote: Buenas,

El error es el siguiente, cuando creo un comando desde el apartado "Comandos" para lanzar alertas de telegram utilizo las comillas, guiones, como vemos a continuación:

bin/telegram-cli –W –e “msg Alertas_Pandora_FMS _field1_” –k /usr/local/src/telegram/tg/tg-server.pub

Ese comando si lo lanzo desde la línea de comandos cambiando el _field1_ por el texto que quiera lo envía sin ningún problema.

El problema viene que al pasar a la pestaña "Acciones" del Pandora FMS los símbolos han cambiado. Me aparece lo siguiente:

bin/telegram-cli –W –e “msg Alertas_Pandora_FMS Caida del dispositivo” –k /usr/local/src/telegram/tg/tg-server.pub

Parece que cambia los símbolos por lenguaje HTML  y de esta manera el comando no funciona. Necesita ayuda!

Gracias a todos!

Buenas tardes, franciscoquintanilla

Por lo que estoy viendo, la ejecución de tu comando está empleando caracteres especiales. Prueba por favor a escribirlo de la siguiente manera: 

Code:
bin/telegram-cli -W -e "msg Alertas_Pandora_FMS _field1_" -k /usr/local/src/telegram/tg/tg-server.pub

¿La macro la está recogiendo correctamente?

Un saludo, 

Eduardo.
 Reply
#3
(04-01-2019, 11:07 AM)eduardo.corral Wrote:
(04-01-2019, 09:12 AM)franciscoquintanilla Wrote: Buenas,

El error es el siguiente, cuando creo un comando desde el apartado "Comandos" para lanzar alertas de telegram utilizo las comillas, guiones, como vemos a continuación:

bin/telegram-cli –W –e “msg Alertas_Pandora_FMS _field1_” –k /usr/local/src/telegram/tg/tg-server.pub

Ese comando si lo lanzo desde la línea de comandos cambiando el _field1_ por el texto que quiera lo envía sin ningún problema.

El problema viene que al pasar a la pestaña "Acciones" del Pandora FMS los símbolos han cambiado. Me aparece lo siguiente:

bin/telegram-cli –W –e “msg Alertas_Pandora_FMS Caida del dispositivo” –k /usr/local/src/telegram/tg/tg-server.pub

Parece que cambia los símbolos por lenguaje HTML  y de esta manera el comando no funciona. Necesita ayuda!

Gracias a todos!

Buenas tardes, franciscoquintanilla

Por lo que estoy viendo, la ejecución de tu comando está empleando caracteres especiales. Prueba por favor a escribirlo de la siguiente manera: 

Code:
bin/telegram-cli -W -e "msg Alertas_Pandora_FMS _field1_" -k /usr/local/src/telegram/tg/tg-server.pub

¿La macro la está recogiendo correctamente?

Un saludo, 

Eduardo.

Buenas Eduardo,

El error estaba que al copiar los comandos de un archivo Word 2016 las comitas eran diferentes a las normales al igual que los guiones.

Ya esta solucionado, muchas gracias!
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes