Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
First time install error (mysql)
#1
I got an error creating the database. I'm using root (so it has all privileges). I've tried to insert sql from cli but it has errors.

I'm stuck on this screen.

[Image: 493744128dba648153f7ef149ea0794f8beb2f54...599209.jpg]
 Reply
#2
(03-26-2019, 09:52 AM)daviduco Wrote: I got an error creating the database. I'm using root user (so it has all privileges).

[Image: 493744128dba648153f7ef149ea0794f8beb2f54...599209.jpg]

Greetings, daviduco

In which OS are you installing Pandora FMS? Also, it would be extremely useful if you could tell us which version are you trying to install.

Which version of MySQL are you running?

Kind regards, 

Eduardo.
 Reply
#3
(03-26-2019, 09:57 AM)eduardo.corral Wrote:
(03-26-2019, 09:52 AM)daviduco Wrote: I got an error creating the database. I'm using root user (so it has all privileges).

[Image: 493744128dba648153f7ef149ea0794f8beb2f54...599209.jpg]

Greetings, daviduco

In which OS are you installing Pandora FMS? Also, it would be extremely useful if you could tell us which version are you trying to install.

Which version of MySQL are you running?

Kind regards, 

Eduardo.

Hi!

OS version
SLES 12 SP3.

Pandora version
I followed this link.
https://wiki.pandorafms.com/index.php?ti...Installing

#SLES 12 SP3
zypper ar -f http://firefly.artica.es/suse PandoraFMS_Official_Repo

MYSQL version
Server version: 10.0.35-MariaDB SLE 12 SP1 package

One more thing, i got this installing the packages (i broke this dependency):

Problem: nothing provides php-mysqlnd needed by pandorafms_console-7.0NG.732-1.noarch
 Reply
#4
(03-26-2019, 10:05 AM)daviduco Wrote:
(03-26-2019, 09:57 AM)eduardo.corral Wrote:
(03-26-2019, 09:52 AM)daviduco Wrote: I got an error creating the database. I'm using root user (so it has all privileges).

[Image: 493744128dba648153f7ef149ea0794f8beb2f54...599209.jpg]

Greetings, daviduco

In which OS are you installing Pandora FMS? Also, it would be extremely useful if you could tell us which version are you trying to install.

Which version of MySQL are you running?

Kind regards, 

Eduardo.

Hi!
OS version
It's SLES 12 SP3.
I followed this link.
https://wiki.pandorafms.com/index.php?ti...Installing

#SLES 12 SP3
zypper ar -f http://firefly.artica.es/suse PandoraFMS_Official_Repo

MYSQL version
Server version: 10.0.35-MariaDB SLE 12 SP1 package

One more thing, i got this installing the packages (i broke this dependency):

Problem: nothing provides php-mysqlnd needed by pandorafms_console-7.0NG.732-1.noarch

Hello daviduco,

Check if in my.cnf file exists this line:

sql_mode=NO_ENGINE_SUBSTITUTION.STRICT_TRANS_TABLES

and edit it as follows:

sql_mode=''

Please, tell us if that was the problem.

Regards.
 Reply
#5
Great, that solved it, thanks so much =D
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes