Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Conflict with Pandora Console 729 and php-mysqlnd in latest CentOS release ?
#1
Hi,

I've had Pandora working for a few weeks on CentOS Linux release 7.5.1804 (Core) 
Over the weekend a big CentOS update was released (centos-release.x86_64 0:7-6.1810.2.el7.centos)
Yum is now failing on a package dependency on Pandora FMS Console.


Code:
[[email protected] centos]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.sov.uk.goscomb.net
* epel: d2lzkl7pfhq30w.cloudfront.net
* extras: centos.serverspace.co.uk
* updates: mirror.sov.uk.goscomb.net
Resolving Dependencies
--> Running transaction check
---> Package GeoIP.x86_64 0:1.5.0-11.el7 will be updated
---> Package GeoIP.x86_64 0:1.5.0-13.el7 will be an update
[snip 300+ lines]
---> Package pandorafms_console.noarch 0:7.0NG.728-1 will be updated
---> Package pandorafms_console.noarch 0:7.0NG.729-1 will be an update
--> Processing Dependency: php-mysqlnd for package: pandorafms_console-7.0NG.729-1.noarch
---> Package pandorafms_server.noarch 0:7.0NG.728-1 will be updated
---> Package pandorafms_server.noarch 0:7.0NG.729-1 will be an update
---> Package pango.x86_64 0:1.40.4-1.el7 will be updated
---> Package pango.x86_64 0:1.42.4-1.el7 will be an update
--> Processing Dependency: fribidi(x86-64) >= 1.0 for package: pango-1.42.4-1.el7.x86_64
--> Processing Dependency: libfribidi.so.0()(64bit) for package: pango-1.42.4-1.el7.x86_64
---> Package perl.x86_64 4:5.16.3-292.el7 will be updated
---> Package perl.x86_64 4:5.16.3-293.el7 will be an update
[snip lots more...]
--> Running transaction check
---> Package dejavu-fonts-common.noarch 0:2.33-6.el7 will be installed
---> Package libglvnd.x86_64 1:1.0.1-0.8.git5baa1e5.el7 will be installed
--> Processing Conflict: php-mysql-5.4.16-46.el7.x86_64 conflicts php-mysqlnd
--> Finished Dependency Resolution
Error: php-mysql conflicts with php-mysqlnd-5.4.16-46.el7.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Any ideas ?
Is this releated to the CentOS update from 7.5 to 7.6 or the Pandora Console update from 728 to 729 ? or both ?

Thanks !

Jon.
 Reply
#2
(12-04-2018, 05:09 PM)JonRussell Wrote: Hi,

I've had Pandora working for a few weeks on CentOS Linux release 7.5.1804 (Core) 
Over the weekend a big CentOS update was released (centos-release.x86_64 0:7-6.1810.2.el7.centos)
Yum is now failing on a package dependency on Pandora FMS Console.


Code:
[[email protected] centos]# yum update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: mirror.sov.uk.goscomb.net
* epel: d2lzkl7pfhq30w.cloudfront.net
* extras: centos.serverspace.co.uk
* updates: mirror.sov.uk.goscomb.net
Resolving Dependencies
--> Running transaction check
---> Package GeoIP.x86_64 0:1.5.0-11.el7 will be updated
---> Package GeoIP.x86_64 0:1.5.0-13.el7 will be an update
[snip 300+ lines]
---> Package pandorafms_console.noarch 0:7.0NG.728-1 will be updated
---> Package pandorafms_console.noarch 0:7.0NG.729-1 will be an update
--> Processing Dependency: php-mysqlnd for package: pandorafms_console-7.0NG.729-1.noarch
---> Package pandorafms_server.noarch 0:7.0NG.728-1 will be updated
---> Package pandorafms_server.noarch 0:7.0NG.729-1 will be an update
---> Package pango.x86_64 0:1.40.4-1.el7 will be updated
---> Package pango.x86_64 0:1.42.4-1.el7 will be an update
--> Processing Dependency: fribidi(x86-64) >= 1.0 for package: pango-1.42.4-1.el7.x86_64
--> Processing Dependency: libfribidi.so.0()(64bit) for package: pango-1.42.4-1.el7.x86_64
---> Package perl.x86_64 4:5.16.3-292.el7 will be updated
---> Package perl.x86_64 4:5.16.3-293.el7 will be an update
[snip lots more...]
--> Running transaction check
---> Package dejavu-fonts-common.noarch 0:2.33-6.el7 will be installed
---> Package libglvnd.x86_64 1:1.0.1-0.8.git5baa1e5.el7 will be installed
--> Processing Conflict: php-mysql-5.4.16-46.el7.x86_64 conflicts php-mysqlnd
--> Finished Dependency Resolution
Error: php-mysql conflicts with php-mysqlnd-5.4.16-46.el7.x86_64
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Any ideas ?
Is this releated to the CentOS update from 7.5 to 7.6 or the Pandora Console update from 728 to 729 ? or both ?

Thanks !

Jon.

Good morning JonRussell,

With the new version of Pandora FMS 729 we changed the version of PHP5 to PHP7, below you can find a link to migrate from one version to the other so Pandora works:

https://wiki.pandorafms.com/index.php?ti..._en:_PHP_7

Alberto
 Reply
#3
Wonderful. Thanks. It's fixed.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes