Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
504 Gateway Time-Out
#11
(09-10-2018, 08:51 AM)jusu Wrote:
(09-05-2018, 08:54 AM)alberto.sanchez Wrote:
(09-04-2018, 11:50 AM)jusu Wrote:
(09-04-2018, 08:26 AM)alberto.sanchez Wrote:
(08-20-2018, 02:39 PM)jusu Wrote: Hello Alberto,

I use an Windows 10 operating system. The pandora_server.conf and the nginx.conf configurations i send you by E-Mail .

Maybe what is still to say is that the web client has ever worked until I made adjustments there in the alarm templates.

Good morning jusu,

After seeing you conf the only thing i can do now it let you the Pandora Wiki about nginx, because i think your ginx configuration is wrong:

https://wiki.pandorafms.com/index.php?ti...n_en:Nginx

try to do a configuration similar than the explained at the wiki and then tell me if the error persists.

Best regards,

Alberto
Hello,

Ok i have adjust my configuration like on Pandroa Wiki but its don't work. Here is my configuration:

user  nginx;


worker_processes  5;

pid        "C:\PandoraFMS/log/nginx.pid";
error_log  "C:\PandoraFMS/log/error.log";

events {
    worker_connections  4096;
}

http {
    include       mime.types;
   default_type  application/octet-stream;

log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  "C:\PandoraFMS/nginx/logs/access.log"  main;

    sendfile        on;

    keepalive_timeout  65;

    #gzip  on;

    server {
        listen       80;
        server_name  192.168.253.253;
  root   "C:\PandoraFMS/htdocs/";
  location ~ \.php {
    fastcgi_pass  127.0.0.1:9123;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include   fastcgi_params;
    include   fastcgi.conf;
  }
  location / {
     alias "C:\PandoraFMS/htdocs/";
           index index.php index.html index.htm;
       }
    }
}

Jusu

Good morning jusu,

Can you please show me the error it gives you after trying with this conf.

Thank you in advanced,

Alberto

Good morning,

2018/09/10 10:55:34 [error] 2476#12016: *13 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: 192.168.253.253, request: "GET /pandora_console/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9123", host: "localhost"

jusu

Good morning jusu,

The only think we can suggest is to give all privileges to the folder  alias "C:\PandoraFMS/htdocs/"; where the index.php is and try it again. We are really mess up with this problem and don`t know what it happens.

Alberto
 Reply
#12
(09-10-2018, 08:51 AM)jusu Wrote:
(09-05-2018, 08:54 AM)alberto.sanchez Wrote:
(09-04-2018, 11:50 AM)jusu Wrote:
(09-04-2018, 08:26 AM)alberto.sanchez Wrote:
(08-20-2018, 02:39 PM)jusu Wrote: Hello Alberto,

I use an Windows 10 operating system. The pandora_server.conf and the nginx.conf configurations i send you by E-Mail .

Maybe what is still to say is that the web client has ever worked until I made adjustments there in the alarm templates.

Good morning jusu,

After seeing you conf the only thing i can do now it let you the Pandora Wiki about nginx, because i think your ginx configuration is wrong:

https://wiki.pandorafms.com/index.php?ti...n_en:Nginx

try to do a configuration similar than the explained at the wiki and then tell me if the error persists.

Best regards,

Alberto
Hello,

Ok i have adjust my configuration like on Pandroa Wiki but its don't work. Here is my configuration:

user  nginx;


worker_processes  5;

pid        "C:\PandoraFMS/log/nginx.pid";
error_log  "C:\PandoraFMS/log/error.log";

events {
    worker_connections  4096;
}

http {
    include       mime.types;
   default_type  application/octet-stream;

log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  "C:\PandoraFMS/nginx/logs/access.log"  main;

    sendfile        on;

    keepalive_timeout  65;

    #gzip  on;

    server {
        listen       80;
        server_name  192.168.253.253;
  root   "C:\PandoraFMS/htdocs/";
  location ~ \.php {
    fastcgi_pass  127.0.0.1:9123;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include   fastcgi_params;
    include   fastcgi.conf;
  }
  location / {
     alias "C:\PandoraFMS/htdocs/";
           index index.php index.html index.htm;
       }
    }
}

Jusu

Good morning jusu,

Can you please show me the error it gives you after trying with this conf.

Thank you in advanced,

Alberto

Good morning,

2018/09/10 10:55:34 [error] 2476#12016: *13 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: 192.168.253.253, request: "GET /pandora_console/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9123", host: "localhost"

jusu

Good morning jusu,

After searching a will i got this info for you:
https://stackoverflow.com/questions/2920...mpt-failed

If not try to use exactly the same conf that in the wiki, with the exact same parameteres.

Alberto
 Reply
#13
(09-13-2018, 08:23 AM)alberto.sanchez Wrote:
(09-10-2018, 08:51 AM)jusu Wrote:
(09-05-2018, 08:54 AM)alberto.sanchez Wrote:
(09-04-2018, 11:50 AM)jusu Wrote:
(09-04-2018, 08:26 AM)alberto.sanchez Wrote: Good morning jusu,

After seeing you conf the only thing i can do now it let you the Pandora Wiki about nginx, because i think your ginx configuration is wrong:

https://wiki.pandorafms.com/index.php?ti...n_en:Nginx

try to do a configuration similar than the explained at the wiki and then tell me if the error persists.

Best regards,

Alberto
Hello,

Ok i have adjust my configuration like on Pandroa Wiki but its don't work. Here is my configuration:

user  nginx;


worker_processes  5;

pid        "C:\PandoraFMS/log/nginx.pid";
error_log  "C:\PandoraFMS/log/error.log";

events {
    worker_connections  4096;
}

http {
    include       mime.types;
   default_type  application/octet-stream;

log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  "C:\PandoraFMS/nginx/logs/access.log"  main;

    sendfile        on;

    keepalive_timeout  65;

    #gzip  on;

    server {
        listen       80;
        server_name  192.168.253.253;
  root   "C:\PandoraFMS/htdocs/";
  location ~ \.php {
    fastcgi_pass  127.0.0.1:9123;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include   fastcgi_params;
    include   fastcgi.conf;
  }
  location / {
     alias "C:\PandoraFMS/htdocs/";
           index index.php index.html index.htm;
       }
    }
}

Jusu

Good morning jusu,

Can you please show me the error it gives you after trying with this conf.

Thank you in advanced,

Alberto

Good morning,

2018/09/10 10:55:34 [error] 2476#12016: *13 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: 192.168.253.253, request: "GET /pandora_console/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9123", host: "localhost"

jusu

Good morning jusu,

After searching a will i got this info for you:
https://stackoverflow.com/questions/2920...mpt-failed

If not try to use exactly the same conf that in the wiki, with the exact same parameteres.

Alberto

Hello Alberto,

i have configurate my nginx.conf new but its don't Work. But I have a new error message in the browser. See attachement. In the Error.log following error

2018/09/26 16:03:15 [error] 1560#9540: *1 CreateFile() "C:\PandoraFMS/htdocs/favicon.ico" failed (2: The system cannot find the file specified), client: 127.0.0.1, server: localhost, request: "GET /favicon.ico HTTP/1.1", host: "localhost", referrer: "http://localhost/pandora_console/index.php"

2018/09/26 16:05:33 [error] 1560#9540: *6 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: localhost, request: "GET /pandora_console/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9123", host: "localhost"


Jusu


Attached Files


.png   Error.PNG (Size: 43.1 KB / Downloads: 2)
 Reply
#14
(09-10-2018, 08:51 AM)jusu Wrote:
(09-05-2018, 08:54 AM)alberto.sanchez Wrote:
(09-04-2018, 11:50 AM)jusu Wrote:
(09-04-2018, 08:26 AM)alberto.sanchez Wrote:
(08-20-2018, 02:39 PM)jusu Wrote: Hello Alberto,

I use an Windows 10 operating system. The pandora_server.conf and the nginx.conf configurations i send you by E-Mail .

Maybe what is still to say is that the web client has ever worked until I made adjustments there in the alarm templates.

Good morning jusu,

After seeing you conf the only thing i can do now it let you the Pandora Wiki about nginx, because i think your ginx configuration is wrong:

https://wiki.pandorafms.com/index.php?ti...n_en:Nginx

try to do a configuration similar than the explained at the wiki and then tell me if the error persists.

Best regards,

Alberto
Hello,

Ok i have adjust my configuration like on Pandroa Wiki but its don't work. Here is my configuration:

user  nginx;


worker_processes  5;

pid        "C:\PandoraFMS/log/nginx.pid";
error_log  "C:\PandoraFMS/log/error.log";

events {
    worker_connections  4096;
}

http {
    include       mime.types;
   default_type  application/octet-stream;

log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  "C:\PandoraFMS/nginx/logs/access.log"  main;

    sendfile        on;

    keepalive_timeout  65;

    #gzip  on;

    server {
        listen       80;
        server_name  192.168.253.253;
  root   "C:\PandoraFMS/htdocs/";
  location ~ \.php {
    fastcgi_pass  127.0.0.1:9123;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include   fastcgi_params;
    include   fastcgi.conf;
  }
  location / {
     alias "C:\PandoraFMS/htdocs/";
           index index.php index.html index.htm;
       }
    }
}

Jusu

Good morning jusu,

Can you please show me the error it gives you after trying with this conf.

Thank you in advanced,

Alberto

Good morning,

2018/09/10 10:55:34 [error] 2476#12016: *13 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: 192.168.253.253, request: "GET /pandora_console/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9123", host: "localhost"

jusu

Good morning jusu,

It's the port of the pass: fastcgi_pass  127.0.0.1:9123; correct?¿ should'nt be another port and thats why it doesn't connect the response?

Alberto
 Reply
#15
(09-27-2018, 09:38 AM)alberto.sanchez Wrote:
(09-10-2018, 08:51 AM)jusu Wrote:
(09-05-2018, 08:54 AM)alberto.sanchez Wrote:
(09-04-2018, 11:50 AM)jusu Wrote:
(09-04-2018, 08:26 AM)alberto.sanchez Wrote: Good morning jusu,

After seeing you conf the only thing i can do now it let you the Pandora Wiki about nginx, because i think your ginx configuration is wrong:

https://wiki.pandorafms.com/index.php?ti...n_en:Nginx

try to do a configuration similar than the explained at the wiki and then tell me if the error persists.

Best regards,

Alberto
Hello,

Ok i have adjust my configuration like on Pandroa Wiki but its don't work. Here is my configuration:

user  nginx;


worker_processes  5;

pid        "C:\PandoraFMS/log/nginx.pid";
error_log  "C:\PandoraFMS/log/error.log";

events {
    worker_connections  4096;
}

http {
    include       mime.types;
   default_type  application/octet-stream;

log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  "C:\PandoraFMS/nginx/logs/access.log"  main;

    sendfile        on;

    keepalive_timeout  65;

    #gzip  on;

    server {
        listen       80;
        server_name  192.168.253.253;
  root   "C:\PandoraFMS/htdocs/";
  location ~ \.php {
    fastcgi_pass  127.0.0.1:9123;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include   fastcgi_params;
    include   fastcgi.conf;
  }
  location / {
     alias "C:\PandoraFMS/htdocs/";
           index index.php index.html index.htm;
       }
    }
}

Jusu

Good morning jusu,

Can you please show me the error it gives you after trying with this conf.

Thank you in advanced,

Alberto

Good morning,

2018/09/10 10:55:34 [error] 2476#12016: *13 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: 192.168.253.253, request: "GET /pandora_console/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9123", host: "localhost"

jusu

Good morning jusu,

It's the port of the pass: fastcgi_pass  127.0.0.1:9123; correct?¿ should'nt be another port and thats why it doesn't connect the response?

Alberto

Hello,

I don't know... Can you say me what's that right Port? and where I can configurate that


Jusu
 Reply
#16
(10-12-2018, 05:53 AM)jusu Wrote:
(09-27-2018, 09:38 AM)alberto.sanchez Wrote:
(09-10-2018, 08:51 AM)jusu Wrote:
(09-05-2018, 08:54 AM)alberto.sanchez Wrote:
(09-04-2018, 11:50 AM)jusu Wrote: Hello,

Ok i have adjust my configuration like on Pandroa Wiki but its don't work. Here is my configuration:

user  nginx;


worker_processes  5;

pid        "C:\PandoraFMS/log/nginx.pid";
error_log  "C:\PandoraFMS/log/error.log";

events {
    worker_connections  4096;
}

http {
    include       mime.types;
   default_type  application/octet-stream;

log_format  main  '$remote_addr - $remote_user [$time_local] "$request" '
                      '$status $body_bytes_sent "$http_referer" '
                      '"$http_user_agent" "$http_x_forwarded_for"';

    access_log  "C:\PandoraFMS/nginx/logs/access.log"  main;

    sendfile        on;

    keepalive_timeout  65;

    #gzip  on;

    server {
        listen       80;
        server_name  192.168.253.253;
  root   "C:\PandoraFMS/htdocs/";
  location ~ \.php {
    fastcgi_pass  127.0.0.1:9123;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    include   fastcgi_params;
    include   fastcgi.conf;
  }
  location / {
     alias "C:\PandoraFMS/htdocs/";
           index index.php index.html index.htm;
       }
    }
}

Jusu

Good morning jusu,

Can you please show me the error it gives you after trying with this conf.

Thank you in advanced,

Alberto

Good morning,

2018/09/10 10:55:34 [error] 2476#12016: *13 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: 192.168.253.253, request: "GET /pandora_console/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9123", host: "localhost"

jusu

Good morning jusu,

It's the port of the pass: fastcgi_pass  127.0.0.1:9123; correct?¿ should'nt be another port and thats why it doesn't connect the response?

Alberto

Hello,

I don't know... Can you say me what's that right Port? and where I can configurate that


Jusu

Good morning jusu,

As i can see in other forums, i see that the port used normally is the 9000. Can you please try this port. You just must change it on the port 9123 that you have.

Alberto
 Reply
#17
(10-16-2018, 07:08 AM)alberto.sanchez Wrote:
(10-12-2018, 05:53 AM)jusu Wrote:
(09-27-2018, 09:38 AM)alberto.sanchez Wrote:
(09-10-2018, 08:51 AM)jusu Wrote:
(09-05-2018, 08:54 AM)alberto.sanchez Wrote: Good morning jusu,

Can you please show me the error it gives you after trying with this conf.

Thank you in advanced,

Alberto

Good morning,

2018/09/10 10:55:34 [error] 2476#12016: *13 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: 192.168.253.253, request: "GET /pandora_console/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9123", host: "localhost"

jusu

Good morning jusu,

It's the port of the pass: fastcgi_pass  127.0.0.1:9123; correct?¿ should'nt be another port and thats why it doesn't connect the response?

Alberto

Hello,

I don't know... Can you say me what's that right Port? and where I can configurate that


Jusu

Good morning jusu,

As i can see in other forums, i see that the port used normally is the 9000. Can you please try this port. You just must change it on the port 9123 that you have.

Alberto

Hello Alberto,

unfortunately that does not work. My idea would be to reinstall Pandora FMS. I can do that without loss of data?

juso
 Reply
#18
(01-07-2019, 09:55 AM)jusu Wrote:
(10-16-2018, 07:08 AM)alberto.sanchez Wrote:
(10-12-2018, 05:53 AM)jusu Wrote:
(09-27-2018, 09:38 AM)alberto.sanchez Wrote:
(09-10-2018, 08:51 AM)jusu Wrote: Good morning,

2018/09/10 10:55:34 [error] 2476#12016: *13 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: 192.168.253.253, request: "GET /pandora_console/index.php HTTP/1.1", upstream: "fastcgi://127.0.0.1:9123", host: "localhost"

jusu

Good morning jusu,

It's the port of the pass: fastcgi_pass  127.0.0.1:9123; correct?¿ should'nt be another port and thats why it doesn't connect the response?

Alberto

Hello,

I don't know... Can you say me what's that right Port? and where I can configurate that


Jusu

Good morning jusu,

As i can see in other forums, i see that the port used normally is the 9000. Can you please try this port. You just must change it on the port 9123 that you have.

Alberto

Hello Alberto,

unfortunately that does not work. My idea would be to reinstall Pandora FMS. I can do that without loss of data?

juso

Hello jusu,


Yes, of course you can. Here is the link to make the backup and restore:

https://wiki.pandorafms.com/index.php?ti...procedures

Jose
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes