Welcome to Pandora FMS Community!

Find answers, ask questions, and connect with our community around the world.

Welcome to Pandora FMS Community Forums Community support Advanced troubleshooting Error on Semaphor version during server update

  • Error on Semaphor version during server update

    Posted by aer on May 31, 2023 at 12:00

    Hi to all,

    I’m a nb of Pandora community version..

    During server update via rpm I receive an error:

    “perl Thread::Semaphore version >= 2.13 should be installed. Current version: 2.12”

    The server version is 769.

    The console version is 771.

    That’s operates on CentOS 7.6.1810 Core version.

    I have installed the latest version of Semaphore and after command

    “semaphore version”

    I receive

    “v2.8.90”

    I sent cpan Thread::Semaphore command but without results.

    Someone can help me?

    Many thanks,

    Massimiliano

    vic replied 10 months, 4 weeks ago 2 Members · 1 Reply
  • 1 Reply
  • vic

    Administrator
    May 31, 2023 at 12:56
    1306 Karma points
    Community awards: bulb Bright ideas
    Community rank: tentacle_master_icon Tentacle Master
    Like it
    Up
    1
    Down
    Drop it
    ::

    Hi Massimiliano,

    It is a new Pandora FMS server dependency, so it is necessary for its correct operation.

    Have you tried to install it with the following commands?

    yum install -y cpanminus
    cpanm -i Thread::Semaphore

    On the other hand, keep in mind that CentOS OS will be obsolete in 2024, so we recommend you to migrate to Rocky Linux 8 or RHEL.

    Best regards,

    Víc.