Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problemas con la actualización Pandora
#1
Hola,

Tenemos Pandora 6 sp1.  Hemos intentado actualizarlo a sp5 y sp6. Cómo siempre lo habíamos hecho hasta ahora. Parar todos los servicios pandora, servidor http y bd.


sudo rpm -ivh   pandorafms_server-6.0SP6-1.noarch.rpm
sudo rpm -ivh   pandorafms_agent_unix-6.0SP6-1.noarch.rpm
sudo rpm -ivh   pandorafms_console-6.0SP6-1.noarch.rpm

Ya con el comando sudo rpm -ivh   pandorafms_server-6.0SP6-1.noarch.rpm nos ha dado errores de dependencia de ficheros. Con lo que lo hemos intentado con el sp2 con el mismo resultado. Así que hemos pasado al plan B. Realizar la instalación con los ficheros Tarball. Hemos realizado lo siguiente




Console update:
tar xvzf pandorafms_console-6.0SP6.tar.gz
cd pandora_console
./pandora_console_upgrade -p /var/www/html/pandora_console

Server update:
tar xvzf  pandorafms_server-6.0SP6.tar.gz
cd pandora_server
./pandora_server_upgrade --upgrade

Agent update:

tar xvzf pandorafms_agent_unix-6.0SP6.tar.gz 
cd  unix
Le damos permisos a pandora_agent_installer
./pandora_agent_installer --force-install


Todo se ha realizado correctamente. Ha solicitado alguna dependecia de perl que hemos instalado.
La versión de s.o es Centos 6.x con todos los parches actualizados. Si hacemos un yum update. Sólo nos sale los paquetes de la versión 7.x de Pandora para actualizar.

La primera cosa que vemos es que en la consola si que marca que la versión de consola es la 6.0 sp6 pero si en el cli utilizo el siguiente comando nos indica que sigue estando en la versión SP1.

[[email protected] ~]# rpm -qa | grep pandora
pandorafms_console-6.0SP1-1.noarch
pandorafms_agent_unix-6.0SP1-1.noarch
pandorafms_server-6.0SP1-1.noarch

¿Se ha actualizado correctamente?

La segunda cosa que estamos viendo, es que teníamos un visual console perfectamente ajustado y ahora se nos ha desajustado las gráficas y las gráficas se ven peor.

¿Es normal?

Por ahora no queremos actualizar a la versión 7.x. Me gustaría saber si el sistema es estable y cómo solucionar lo que os he indicado.

Gracias
 Reply
#2
Buenas ansator3,

Sí se ha actualizado correctamente, "rpm -qa" muestra los últimos paquetes instalados mediante rpm, como has actualizado mediante los tarball no se ve reflejado.

Saludos!

vic.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes