Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error en Check HTTP Server
#1
Hola,

para un agente he añadido un módulo basado en Check HTTP Server, en IP objetivo he puesto el nombre del dominio, puerto 80, en la caja de texto Enviar TCP he puesto:

GET / HTTP/1.1^M
HOST:www.dominio.es^M^M

Y en la caja de texto Recibir TCP, he puesto:
HTTP/1.1 200 OK

Curiosamente siempre recibo que el sevidor web está caído.

Como administro también el servidor, he estado depurando las peticiones, y no me llega ninguna desde Pandora, y no tengo firewalls por en medio que puedan estar cortando el tráfico.

Si hago un telnet al puerto 80, con esos mismos datos, la respuesta es correctamente la que espero recibir.

Por si guarda alguna relación, estoy corriendo Pandora FMS, sobre una Debian 8.7 y es la versión Pandora FMS v6.0SP3 - Revisión PC160627.

¿Alguna sugerencia?

Gracias de antemano.
 Reply
#2
Hola, también tuvve ese roblema, al parecer es algun tema de la versión del servidor (no estoy seguro). En todo caso yo bajé un plugin llamado WebsiteMonitor y me funciona bien:

http://library.pandorafms.com/index.php?...id_PUI=447
 Reply
#3
Hola XyVy,

Sí que puede guardar relación. Para depurar con mayor precisión el problema y poder determinar la causa, te sugiero que incrementes el parámetro "verbosity" del fichero pandora_server.conf a valor 10, después reinicia el servicio pandora_server para aplicar cambios.
Desde este momento toda la actividad del server se reflejará en el fichero pandora_server.log, por lo que puedes forzar la ejecución del módulo y verás en el log qué está ocurriendo, y si devuelve algún fallo.

Un saludo,
Antonio.
 Reply
#4
Gracias a ambos, al final actualicé a SP4 y ahora me funciona correctamente el Check HTTP Server.

 Reply
#5
Hola XyVy,

Me alegro de que ya esté solucionado. Por curiosidad, averiguaste cuál era la causa?

Un saludo,
Antonio.
 Reply
#6
Pues esta vez no me calenté mucho la cabeza en ver cual era el problema, si bien si observé que no recibía las peticiones HTTP en el servidor Web, asumo que el problema sería de lanzar el conveniente script que solicitara los datos, pero ya digo no depuré, lo siento.

Un saludo.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes