Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update manager
Hi to everyone:
I'm trying to update pandorafms trough the Update Manager (currently have version 161024). The system is showing me  there 's a new version (version 161107). When i proceed to update to the latest version i take a long period running th eprogress bar and finally i get a message:

There is an unknown error

Checking the system logfiles i found this in the Pandora Console logs:

[07-Nov-2016 11:54:13 America/New_York] PHP Fatal error:  Uncaught exception 'UnexpectedValueException' with message 'phar error: "/var/www/pandora_console/attachment/downloads/last_package.tgz" is a corrupted tar file (checksum mismatch of file "30 mtime=1478508903.853688924
30 atime=1478508902.665625322
30 ctime=1478508903.853688924
")' in /var/www/pandora_console/include/functions_update_manager.php:613
Stack trace:
#0 /var/www/pandora_console/include/functions_update_manager.php(613): PharData->__construct('/var/www/pandor...')
#1 /var/www/pandora_console/include/ajax/update_manager.ajax.php(488): update_manager_starting_update()
#2 /var/www/pandora_console/ajax.php(86): require_once('/var/www/pandor...')
#3 {main}
  thrown in /var/www/pandora_console/include/functions_update_manager.php on line 613

What can be causing this? Any help?????

I have the same problem, you have solved?


we got the same message, what is the correct way to solve the update problem?



per risolvere il problema di aggiornamento online per la versione community devi riscaricare il pacchetto della console in versione SP3 dal link , installarlo nuovamente e successivamente continuare normalmente gli aggiornamenti.
Translated to English:

to solve the problem of online update for the version you have to re-download the community version of the SP3 package from the console link, reinstall it, and then continue as normal updates.
I just installed fresh, on a fresh Debian VM... And I'm getting that error too.

Not sure if it's relevant but if I gunzip the tgz file, I get this message:
gzip: last_package.tgz: decompression OK, trailing garbage ignored
This gives a return code of 2, not a happy 0.

Extracting the tar directly using tar -zxf also results in an exit code of 2 with this output:
gzip: stdin: decompression OK, trailing garbage ignored
tar: Child returned status 2
tar: Error is not recoverable: exiting now

I personally solved the problem by turning off update checks.... Not ideal of course.

Edit: I just re-read the OP's log output, and mine is a little different....
[04-Feb-2017 00:05:46 Australia/Sydney] PHP Fatal error:  Uncaught exception 'UnexpectedValueException' with message 'unable to decompress gzipped phar archive "/var/www/html/pandora_console/attachment/downloads/last_package.tgz" to temporary file' in /var/www/html/pandora_console/include/functions_update_manager.php:624
Stack trace:
#0 /var/www/html/pandora_console/include/functions_update_manager.php(624): PharData->__construct('/var/www/html/p...')
#1 /var/www/html/pandora_console/include/ajax/update_manager.ajax.php(488): update_manager_starting_update()
#2 /var/www/html/pandora_console/ajax.php(89): require_once('/var/www/html/p...')
#3 {main}
  thrown in /var/www/html/pandora_console/include/functions_update_manager.php on line 624
Not solution yet for this issue?

The problem here is we are not able to replicate the issue on our testing environments, so the cause is not clear and may be different on different scenarios (different distros and/or system configurations).
As a "reset" I'd recommend to make the update/installation with the most recent package manually (either deb or rpm), so we can ensure there are no code errors.

Remember to always make backups of the database and most important configuration files (include/config.php and pandora_server.conf) before making interventions on the monitoring systems.

Kind regards,
So this is still happening for me in 7.0... And I fresh installed the 7.0 package, so it's clean.
The error I get is now "Error in package extraction." which seems to be different text, but the same result.

I watched the download directory while I ran the update, and it drops a tar file in there, then a directory is created, then the error appears and the tar file disappears....

Nothing seems to be logged anymore during this process, which makes it difficult to debug. Is there a setting for increasing the debugging logs?
Hello tin,

Is that a new ISO installation? I've tried on a new one and I've been able to successfuly update to the package 170424.

Make sure you disable firewalld and selinux:

# service firewalld stop
# setenforce 0

Let me know if that makes a difference.

I've seen the file last_package.tgz file being created but not being removed after completing the update.

Kind regards,

Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes