Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error Umbral de tiempo en alerta
#1
Hola de nuevos amigos

Hoy tengo 2 problema con las alertas. He definido que se dispare como acción el envío de correo cada 6 hora, lo cual hace todo correctamente. El problema es que lo hace cada 4 horas y no se a que se debe.

Por otro lado otra alerta con los mismos parámetros, ayer comenzó a enviar correos cada 5 minutos, mientras el resto de alerta seguía en 4 horas (que debería ser 6)

¿a que se debe este comportamiento?

Adjunto imagen con la configuración de la alerta...

Tengo la versión 6.0 - Revisión PC151126


Attached Files


.png   Error Alerta.png (Size: 17.42 KB / Downloads: 65)
 Reply
#2
Veo que luego de 3 días mi consulta no tiene respuesta alguna. Sin embargo, les comento que tengo avances.

Primero, creo que debe haber algún error en la programación del código puesto que tuve que cambiar las alertas (mas de 200) a otro umbral de horas (de 6 horas a 12 horas) sin embargo, el problema se mantiene, es decir, ahora las alertas llegan cada 10 horas (2 horas igual que antes). Por lo que deduzco que las opciones que entrega el sistema están mal.

Por otro lado, pude solucionar la alerta cada 5 minutos que me enviaba otro cliente. Lo único diferente era que el cliente tenía mal la hora y había una diferencia de 4 horas. Al corregir esto, las alertas comenzaron a llegar como corresponde. Lo extraño es que en el mismo cliente habían otras alertas, pero no sucedía nada extraño con esas alertas.

Que tengan buen día.
 Reply
#3
Hola jpegazo,

No entiendo muy bien en qué punto te encuentras actualmente.

Si configuras que una alerta con una condición (como pueden ser Critical o Warning) se lance desde dentro de un periodo de tiempo, por ejemplo, 6 horas, no significa que a las seis horas vayas a recibir un correo, sino que este será enviado dentro de este periodo, es decir, a lo largo de las seis horas, pudiendo ser a las 3, 4:57 o 6. ¿Qué clase de alerta es? Perdona de antemano si no entiendo bien tu problema.

Un saludo,
Emilio.
 Reply
#4
Entiendo que la opción del umbral me envía una alerta (en este caso correo) cada X tiempo siempre y cuando el estado de la alerta no se normalice. De hecho este comportamiento es así. Lo que pasa es que del listado que indica la consola, hay una diferencia de 2 horas con respecto a lo que realmente alerta. Es decir, hoy tengo seleccionada la opción de 12 horas y me alerta cada 10 horas (exactas) y recibo un correo en ese tiempo.

Por otro lado la definición que me indicas, creo que está errónea. Cito textual la definición que aparece en http://wiki.pandorafms.com/index.php?tit...emplate.29

Time threshold: Por defecto es un día. Si un módulo permanece todo el rato caído, durante, por ejemplo un día, y tenemos aquí un valor de 5 minutos, significa que nos estaría mandando alertas cada 5 minutos. Si lo dejamos en un día (24 horas), sólo nos enviará la alerta una vez, cuando se caiga. Si el modulo se recupera, y luego se vuelve a caer, nos enviará una alerta de nuevo, pero si sigue caída desde la 2º caida, no enviará mas alertas hasta dentro de 24 horas.

A lo que voy es la diferencia de horas que está definida.

6 horas: Envía alerta cada 4 horas
12 horas: Envía alerta cada 10 horas

Saludos.
 Reply
#5
Hola jpegazo,

¿Continúas teniendo este problema? ¿O quedó solucionado al definir bien las alertas? (Comento esto por tu otro post)

Un saludo,
Emilio.
 Reply
#6
El problema se mantiene, con 2 horas desface en el envío de alertas.
 Reply


Users browsing this thread: 2 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes