Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
fallo de los monitores después de upgrade a 6.0
#1
Hola buenos días,

He realizado un upgrade según este procedimiento desde la versión 5.1 a la 6.0
http://wiki.pandorafms.com/index.php?tit...ra_Upgrade
Y ahore veo que los monitores que tenía sobre agentes snmp de red no me funcionan.
¿podrían ayudarme a ver qué está pasando?.

He visto el siguiente mensaje en el fichero pandora_server.error una vez arranco el servidor:

Value "_field1_" invalid for option p (number expected)
Use of uninitialized value $signal in concatenation (.) or string at /usr/bin/pandora_server line 58, <SNMPLOGFILE> line 1.
kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
Can't locate PandoraFMS/Enterprise.pm in @INC (@INC contains: /usr/lib/perl5/5.10.0 /usr/lib/perl5 /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor
_perl /usr/share/perl5/vendor_perl /usr/share/perl5 .) at (eval 65) line 1.
2016-01-07 14:57:59 - localhost.localdomain Starting Pandora FMS Server. Error logging activated.
ERROR 2005 (HY000): Unknown MySQL server host '_field1_' (0)
Value "_field1_" invalid for option p (number expected)


Por si sirve de algo.

Gracias.
 Reply
#2
Hola,

He descubierto que el problema de los monitores no funcionando es debido a que el server pandora_server se cae con bastante frecuencia.
¿Alguien sabe a qué podría ser debido?
 Reply
#3
Hola Jramongv,

¿Podrías adjuntar el fichero log del server?
¿Qué sistema operativo y versión del mismo usas exactamente?

Un saludo,
Emilio.
 Reply
#4
Hola Emilio,

He estado viendo en otros hilos y al final he resuelto el problema incluyendo la libreria Encode en el fichero /usr/lib/perl5/PandoraFMS/Core.pm
tal y como se indica en este hilo
http://forums.pandorafms.com/index.php/t...67.30.html
No se si se ha tratado de algún error y se ha corregido en algún update, pero de momento a mi me está funcionando bien.

tengo un Centos 6.6 de 64 bits.
 Reply
#5
Hola Jramongv,

El problema que mencionas ha sido solucionado. En próximas semanas saldrá la sp1 de la versión 6, actualizando el servidor Pandora entonces debería solucionarse.

Un saludo,
Emilio.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes