Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
migrar de 5.0 a 5.2
#1
Buenas!

Pregunto si se puede hacer del tirón, sin tener que pasar por la v5.1.

¿hay doc al respecto? No la he visto al menos.

Muchas gracias por todo.
 Reply
#2
Buenos días Kikelin,

imagino que te refieres a migrar de las versión 5.0 a la 5.1 SP2. Lo primero que te recomiendo es que realices copias de seguridad de los archivos de configuración del servidor y de la consola. Realiza también un backup de la base de datos de pandora antes de iniciar cualquier instalación.

Actualiza los paquetes rpm de la consola que ya tienes instalados.

Actualiza la base de datos de pandora con:
      mysql -u[usuario] -p[password] -D pandora
      source /var/www/html/pandora_console/extras/pandoradb_migrate_5.0.x_to_5.1.mysql.sql

Actualiza los paquetes rpm del servidor que ya tienes instalados.

En líneas generales ese es el proceso, de todas formas encontrarás información mucho más detallada en el siguiente enlace:
http://wiki.pandorafms.com/index.php?tit...on_Pandora

Un saludo!

 Reply
#3
Gracias Javier,

El problema es que en esa dirección, solo tengo ficheros para migrar hasta la versión 5.0, es decir, para migrar de la 3.x a la 4.x y de la 4.x a la 5.0.

Muchas gracias.
 Reply
#4
Resuelto con un apt-get update/upgrade

Gracias!!
 Reply
#5
Buenas!

He migrado mi servidor pandora. He montado uno limpito desde 0 con la version 5.1sp2, al que luego le he cargado una base de datos de mi servidor 'sucio' en la versión 5.1sp2.

He detectado que muchos de mis agentes con módulos icmp de host_alive, no están funcionando adecuadamente.

Es curioso, porque tengo un agente con 55 módulos de host_alive y me están funcionando unos sí y otros no, cuando de siempre han sido iguales.

Alguna idea.
 Reply
#6
Buenas tardes,

al montar el servidor desde cero el archivo de configuración pandora_server.conf ha establecido los valores por defecto. ¿Es posible que en el antiguo servidor aumentaras el número de hilos dedicado al networkserver? De ser así, prueba a aumentarlos también en el archivo de configuración del nuevo servidor a ver si te funcionan correctamente los 55 módulos.

Un saludo!
 Reply
#7
Buenas!!

En realidad, despues de montarlo de 0, le he actualizado el server.conf y agent.conf con el del server antiguo ... entendería que el problema debe ser otro.

No me suena haber tocado eso que comentas, pero si me das algo más de info reviso.

Muchas gracias por todo.
 Reply
#8
Ok, mira a ver entonces en la consola de Pandora, en la pantalla de edición del agente a qué servidor está asociado. Es posible que al volcar la base de datos antigua mantenga un nombre de servidor distinto al que usas ahora.

Un saludo!
 Reply
#9
Perfecto, el problema que tenía era que el hostname era distinto.

Al ponerlo igual que el inicial en el nuevo server, y eliminar agentes creados, se ha reproducido a la perfección, incluso manteniendo sus alertas y dem.as.

SOLVED.

Muchísimas gracias por todo.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes