Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Next contact: Out Of Limits
Hello. Ran across Pandorafms looking for a Nagios replacement... and must say that I am in love with this!

I am having an odd issue though. Both with a VM and on a separate physical machine. I have gone through the WIKI and several other things on the net dealing with PHP and xml. Everything appears to be set correctly and the times across the system match up. But my agents will not check. This happened after I rebooted the physical server after the inital appliance CD install.

Here's the system data and things I have gone through thus far. The only thing I cannot change and keep the change applied is for mysql. But its pulling from the system time so it should be correct.

TZ's have all been set to: America/New_York

Pandora -> Setup:  America/New_York

WIKI Items:
Set the zones in include/config_process.php.

# date +"%z"
# date
Wed Mar 18 14:43:13 EDT 2015

mysql> select now();
| now()              |
| 2015-03-18 14:43:46 |
1 row in set (0.00 sec)

mysql>  SELECT @@global.time_zone, @@session.time_zone;
| @@global.time_zone | @@session.time_zone |
| SYSTEM            | SYSTEM              |
1 row in set (0.00 sec)

]# perl -e 'my $t = localtime(); print "$t";'
Wed Mar 18 14:44:38 2015

    echo date("Y/m/d H:iConfused O e");
Returns - 2015/03/18 14:45:00 -0400


Also found an addition to the php test file to see if the ini/server tz was the same. It reports it is correct:

$script_tz = date_default_timezone_get();

if (strcmp($script_tz, ini_get('date.timezone'))){
    echo 'Script timezone differs from ini-set timezone.';
} else {
    echo 'Script timezone and ini-set timezone match.';

Returns: Script timezone and ini-set timezone match.

hwclock --debug
hwclock from util-linux-ng 2.17.2
Using /dev interface to clock.
Last drift adjustment done at 1426696800 seconds after 1969
Last calibration done at 1426696800 seconds after 1969
Hardware clock is on UTC time
Assuming hardware clock is kept in UTC time.
Waiting for clock tick... clock tick
Time read from Hardware Clock: 2015/03/18 19:32:48
Hw clock time : 2015/03/18 19:32:48 = 1426707168 seconds since 1969
Wed 18 Mar 2015 03:32:48 PM EDT  -0.937902 seconds
Correct time... got held up posting


Attached Files

.png   Capture.PNG (Size: 5.31 KB / Downloads: 131)
I have also tried changing Timestamp or time comparation in setup. As well as enabling use_xml_timestamp 1 in the pandora config.

What I find really odd - The local agent/modules the server created check fine.
Tried re-creating modules on a server this morning hoping something was just screwed up with them. They came back as non initialized modules.

This is happening on a fresh install from the appliance CD on your website!

Attached Files

.png   Capture.PNG (Size: 183.22 KB / Downloads: 150)
Here is the diagnostic info. Attached is the data file

php /var/www/html/pandora_console/extras/pandora_diag.php /var/www/html/pandora_console

Pandora FMS PHP diagnostic tool v3.2 © Artica ST 2009-2010
Pandora FMS Build|PC150319
Pandora FMS Version|v5.1SP2
PHP Version|5.3.3
DB Table tagente|15
DB Table tagent_access|598
DB Table tagente_datos|9019
DB Table tagente_datos_string|815
DB Table tagente_estado|48
DB Table tagente_modulo|48
DB Table talert_actions|5
DB Table talert_commands|12
DB Table talert_template_modules|14
DB Table tevento|322
DB Table tlayout|0
DB Table tserver|10
DB Table treport|0
DB Table ttrap|0
DB Table tusuario|1
DB Table tsesion|131
DB Schema Version|5.1SP2
DB Schema Build|PD150223
Enterprise installed|
PandoraDB Last run|2015/03/19 11:01:02
Updating code path|Path where the updated code is stored
Current Update #|412

mysql> show variables like '%time_zone%';
| Variable_name    | Value  |
| system_time_zone | EDT    |
| time_zone        | SYSTEM |
2 rows in set (0.00 sec)

| 11:55:09    |
1 row in set (0.00 sec)

mysql> Ctrl-C -- exit!
[[email protected] ~]# date
Thu Mar 19 11:55:12 EDT 2015

Attached Files

.txt (Size: 75.71 KB / Downloads: 105)
Figured it out. Server hostname was changed from localhost to chm-watchdog. All of the agents were looking for localhost... thus the out of limits. Silly... but for anyone else having trouble check there.

Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes