Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] No WMI After Upgrade [Error with WMI Explorer]
After upgrade, WMI modules never initialize.

Upgrade steps performed. On working 5.0 SP4. Which was an updated appliance.

Below are my upgrade steps:
# /etc/init.d/pandora_server stop
# /etc/init.d/tentacle_serverd stop
# yum upgrade -y
(installs new RPMs, pandorafms_server, _console, _agent_unix)
# cat /var/www/html/pandora_console/extras/pandoradb_migrate_5.0.x_to_5.1.mysql.sql | mysql -uroot -pXXXXXXXXXXXXXX -D pandora
# /etc/init.d/pandora_server start
# /etc/init.d/tentacle_serverd start
# /usr/share/pandora_server/util/ pandora localhost pandora XXXXXXXXXXXXXX
(1 script migrated)

If I execute the WMI command manually it works fine.

The log shows:
"2014-07-15 10:00:43 [V9] Executing AM # 3133 WMI command 'wmic -U "xxxxx/xxxxx"%"xxxxxx" --namespace="ROOT\CIMV2" //xxx.xx.x.xx "select PercentFreeSpace from Win32_PerfFormattedData_PerfDisk_LogicalDisk WHERE name = 'C:'"'
2014-07-15 10:00:43 [V10] Updating module Free Disk Space C: % (ID 3133) on error.



Can you send us a copy of the execution of the command manually in a terminal and a screencapture of the module configuration.

Please keep in mind that I am providing a limited example. I have over 400 WMI modules in use in total. None of them will initialize after the upgrade.

[[email protected] pandora]# wmic -U XXX/XXX%XXX --namespace="ROOT\CIMV2" //x.x.x.x "select Name from Win32_PageFileUsage"

CLASS: Win32_PageFileUsage

Screenshot of module:

[Image: 160setv.png]
Below is the corresponding log file entry:

2014-07-23 14:39:57 [V9] Executing AM # 3126 WMI command 'wmic -U "xx/xxx"%"xxx" --namespace="ROOT\CIMV2" //x.x.x.x "select Name from Win32_PageFileUsage"'

2014-07-23 14:39:57 [V10] Updating module Page File Location (ID 3126) on error.

Why you are using the field Namespace?

Have you tried using only Username:, Password and Query??

Thank you for this discovery.

There is no specific reason why this is being used. But it is configured on all of my WMI modules.

From the GUI
In version 5.0 the back or forward slash "\" "/" works.
In version 5.1 only the forward slash "/" works.

From the CLI
Only the forward slash "/" works in both versions.

Is version 5.0 translating this on execution?

Do you know any way to change all the modules "/", or remove that field? I don't see that filed in the "Massive operations."

You can't do it massively, but you can change it by mysql query:

update tagente_modulo set tcp_send = "/" where id_tipo_modulo = 3

Before to run this query, run this:

select * from tagente_modulo where id_tipo_modulo = 3

and check if all modules are WMI modules.

Good Day,

Query: select * from tagente_modulo where id_tipo_modulo = 3;

Is returning 243 rows.

I have 424 WMI modules.

If I apply the update, I can confirm that it in fact only updates about half of them.

Any ideas?
Oh Sorry,

id_tipo_modulo=3 is the type generic_data_string, not only WMI. Not exist any option to see only WMI modules in database. Only you can change it manually or if you have agents only with WMI modules, you can select the query as id_agent and change all modules at same time.

I understand.

Wouldn't the below sql query accomplish the task of removing the entry?

update tagente_modulo set tcp_send = replace(tcp_send, ‘ROOT\CIMV2’, ‘’);

Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes