Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error en la actualización de 4.1 a 5.0
#1
Hola

Al actualizar un servidor de pandora de la 4.1 a la versión 5.0, me encontré que el servicio pandora_server no inicia. No encontraba el campo last_error.

Logré detectar el causante del error a base de comparar la base de datos antigua (después de actualizar), con una nueva que creé: Dentro del paquete pandorafms.console_5.0.deb el archivo /var/www/pandora_console/extra/pandoradb_migrate_4.1_to_5.0.mysql.sql le falta añadir el campo last_error en la tabla tagente_estado.

Aqui dejo el parche:
--- pandoradb_migrate_4.1_to_5.0.mysql.sql      2013-10-17 11:02:20.000000000 +0200
+++ pandoradb_migrate_4.1_to_5.0.mysql.sql_new  2013-10-18 19:35:46.000000000 +0200
@@ -360,6 +360,7 @@
-- Table `tagente_estado`
-- ----------------------------------------------------------------------
ALTER TABLE `tagente_estado` ADD COLUMN `last_known_status` tinyint(4) NOT NULL DEFAULT 0;
+ALTER TABLE `tagente_estado` ADD COLUMN `last_error` tinyint(4) NOT NULL DEFAULT 0;

-- ---------------------------------------------------------------------
-- Table `tevent_response`


Bueno, a mi me funcionó y solucioné el problema de la actualización satisfactoriamente.


Attached Files


.   patch_last_error (Size: 565 bytes / Downloads: 24)
 Reply
#2

Hola buenas

La versión 4.1 que tenías instalada, era inicial, o estaba ya actualizada de otras versiones anteriores??

Gracias
 Reply
#3
Buenos días:

Gracias por el parche, he tenido el mismo error.

Un saludo.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes