Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No se recupera estado host alive
#1
He montado un agente básico que monitoriza acceso a "internet": www.google.es
Este tiene 2 monitores del tipo: Host Alive y Host Latency

Durante un tiempo funcionan correctamente, pero finalmente acaban cayendo en estado crítico (pierde ping en el caso del host alive) y ya no se vuelve a recuperar.
Si entro en la consola de comandos del servidor pandora, hago ping a www.google.es sin problemas.

La única forma que he encontrado de recuperar el estado es reiniciar pandora, y automáticamente todo ok.

Pandora FMS v4.0.3 - Build PC130331
 Reply
#2
Buenas

Comprueba la carga y el retraso que tiene el servidor de Red en la vista de servidores. Si es elevado sube el numero de hilos del servidor.
Si el retraso del mismo no es tan elevado o nulo, modifica en el archivo de configuración del servidor los chequeos icmp que estaran a uno y ponlo a 2.
(icmp_checks 2).

Nos informas si tras estos cambios obtienes alguna mejora.

Un saludo
 Reply
#3
No se si se analizar el tema de la carga, aunque debería ser nimio, a ver si el pantallazo que adjunto aclara algo.

Sobre el parámetro icmp_checks, lo he puesto a 4, para que vaya holgado, y de nuevo se he reproducido el problema.
Reinicio servidor y todo ok, en esta ocasión al cabo de pocos minutos ya no se recupera.
Verifico nuevamente ping des de la línea de comandos, todo ok.

Puntualizo también, que el monitor "Host Latency" no devuelve ningún valor, es decir, fallan ambos monitores la mismo tiempo.

Me he dado cuenta que el fallo es general del Pandora Network Server, ya que todos los Host Alive que tengo, están caídos, y no se recuperan.

Gracias por tan rápida respuesta!
--
Jose


Attached Files


.png   04-04-2013 12-02-02.png (Size: 25.31 KB / Downloads: 54)
 Reply
#4
Hola Jose

Los icmp_check mas altos lo que te provoca es más carga en el servidor por lo que no te ayuda, más de 2 no es necesario, además por la carga que tiene el servidor de red no considero que sea un problema de carga.
¿Cuales son las prestaciones del equipo? Estoy observando también que tiene mucho retardo en el servidor de datos para los módulos que tiene, en el servidor de datos si le haría falta subir el número de hilos a 2.
¿Has comprobado si el dato te devuelve 1 o 0? Es decir si el modulo devuelve 1 y luego te aparece en estado critical o por el contrario esta reportando un 0 tal y como muestra el estado.
¿Has instalado la 4.0.3 desde el principio o es una actualización de versiones anteriores?

Un saludo
 Reply
#5
Ok, he puesto icmp_check en 2, tal y como me recomiendas.
El equipo es una máquina virtual en ESXi con 1GB de RAM, que monta la Virtual Appliance 4.0.3 (descargada hace 1 semana aprox.), posteriormente se han hecho 2 updates directamente desde la consola gráfica.

¿Cómo se sube el número de hilos?

Acabo de ver que el tema de la latencia ahora es muy diferente, ver adjunto.

Adjunto otro pantallazo con la gráfica del monitor en un rango de 12h, llevaba varios días en critical y aquí se pueden ver claramente los 3 reinicios.


Attached Files


.png   04-04-2013 14-05-24.png (Size: 8.13 KB / Downloads: 48)
 Reply
#6
El adjunto que no ha subido...


Attached Files


.png   servidores.png (Size: 24.99 KB / Downloads: 58)
 Reply
#7
Ok.

Para cambiar los hilos de los servidores de Pandora, los puedes cambiar en el archivo de configuración del servidor, es el parámetro dataserver_threads.

Actualmente tengo instalada una Appliance sobre Vbox que esta funcionando correctamente con estos tipos de módulos, pero aún asi te voy a indicar unos pasos a seguir, para descartar problemas con el servidor pandora en el Appliance

1.- Descarga el paquete rpm del servidor pandora  (http://sourceforge.net/projects/pandora/...m/download)

2.- Para el servidor ( /etc/init.d/pandora_server stop) y realiza una actualización del servidor forzándolo ( rpm -U --force <nombre_paquete.rpm> ) .

3.- Reinicia todos los servicios con los que trabaja Pandora. ( apache, mysql, tentacle, pandora_server )
/etc/init.d/apache2 restart
/etc/init.d/mysql restart
/etc/init.d/tentacle_serverd restart
/etc/init.d/pandora_server restart

Una  vez esto comprueba el funcionamiento de los módulos. Comprueba también los logs para ver si nos devuelven alguna información al respecto.

Un saludo


 Reply
#8
Mario,
He hecho todos los pasos que me has indicado a pies juntillas.
De momento todo va bien, esperaré 3-4 días, ya que ese es el tiempo máximo que me aguantó el monitor desde que lo pusimos en marcha.

En cualquier caso el tema de la actualización forzada, que sugiere? Que la compilación appliance viene con algún problema? Para montarla en el ESXi tuve que usar el converter...

Gracias!
 Reply
#9
No ha habido suerte. Todo sigue igual.
Ahora mismo todos los monitores de red inoperativos desde las 23:20 de ayer...

¿Qué mas podemos revisar?

Gracias!


Attached Files


.png   05-04-2013 10-56-42.png (Size: 8.28 KB / Downloads: 43)
 Reply
#10
Vaya!

En el archivo de configuración de Pandora existe un parámetro llamado verbosity y viene configurado por defecto a 1. Configúralo a 10 y reinicia el servidor de Pandora. Con esta configuración los logs nos van a devolver más información al respecto.
¿De cuanto tiempo es el intervalo de ejecución de estos módulos? Si es menor a 5 minutos, configúralo a 5 para ver si de este modo reportan correctamente.

Un saludo
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes