Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Agente no envía datos
#1
Utilizamos la versión 3.2.1 de pandora y hace un tiempo que hemos detectado que los agentes instalados en Windows server dejan de enviar los datos durante unas horas y luego se vuelven a recuperar.

He podido observar que cuando dejamos de recibir los datos, los ficheros que se generan se van almacenando. En la carpeta temporal definida en el fichero de configuración. Y cuando me conecto por terminal server para ver qué pasa, el agente empieza a enviar los datos. Da la sensación que el agente no puede crear la conexión, por eso querría saber si hay forma de forzar al agente para crear la conexión o ver con más de talle lo que está pasando.

Todas las prueba manuales de conexión que hemos realizado (conectados por terminal server) funcionan como es el telnet, el ssh y el tentacle pero de forma automática, el agente no lo envía ¿Alguna idea?
 Reply
#2
Hola jmunozpa,

Una prueba que puedes hacer es:

Cuando deje de reportar, entra en la máquina y envía a mano un archivo usando tentacle_client para ver que error da. El comando sería:

tentacle_client.exe -a <server_ip> <file_name>

Con esto verás si tentacle tiene algún problema y a partir de ahí podemos ver el problema más concreto.

Un saludo.

Darío.
 Reply
#3
Gracias darode.

Esta prueba la he realizado y funciona sin reportar errores. Incluso lo he realizado con SSH y tampoco da errores. Es muy curioso pero da la sensación que es problema de comunicaciones.

De momento lo he solucionado poniendo en el agene el módulo de Host Alive. Pero seguimos mirando las comunicaciones a ver si hay algún firewall que nos bloquea.

Saludos,
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes