Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] SSH authentication failed
Hi guys, i'm new in Babel Enterprise platform, but i'm experiencing a problem with authentication handshake between a WinXP host (with Babel Agent 1.1) and a Fedora Core 8 Server (MySQL, Apache 2.x and PHP 5.x).

This is my "BabelService --test-ssh" output:

Public key file C:\Programmi\Babel Enterprise\key\ exists.
Private key file C:\Programmi\Babel Enterprise\key\id_dsa exists.
Connecting with
Authentication Failed when connecting to
Reason: Username/PublicKey combination invalid
Check the remote host configuration and the public/private key files.

Now, i think that i've configured the public/private pair keys correctly....but i can't log in the agent into server with SSH....why?
Hi, good nick :-)

Well, ssh keys in windows systems are actually hell on earth, I tell you.

Assuming you exported rightly all the ssh-keys generated following the manual, it's very likely the process went wrong when copying the ssh key to the server, cause the linux keys are working properly, right?

If so, you might want to copy the windows's key to a notepad and make sure there're no blank spaces and put all of it in the same line. Copy it and paste it in the linux file.
Make sure there's no white line at the end of the file, if there is, it will fail.
Hi and thanks for the quick reply.

Ok, i've check the DSA-key, i use Putty-gen to generate Private/Public OpenSSH you know Puttygen, right? Big Grin

So, when i copy the string to notepad and then i put it in the same line there're no blank spaces. This is a sample string (public key):

ssh-rsa AAAAB3NzaC1yc2EAAAABJQAAAIBeVRnc2OCH1wZ7pQwlT0R2euTzFaFg7+YHLaXzAYrxWcNjW1Z2m/aM0VaMK0ygM+LmSFvhOHW0DgVA8z22tvQfQqNEqr4SxATAG6sgd9EL7Ve1h3LxrWTk2yEoByHLerx9zKUBd3tBJhiCaa55artVYcmcHzCT4C3eA9fAYR7sfQ ==rsa-key-20080429

Now, how can be that there's no match between the two public keys?
You can check the procedure to set the keys at

This document was made for Pandora FMS, but the procedure it's the same.

Nothing......there's something that wrong with sshd and babel......i don't know.....but it's impossible to understand why there's this problem....

I've tried with Fedora 7 and i can't neither install Babel Server 1.1 because there're problems with glib, pango, cairo&freetype, pixma, pkg-config.....

-_- it's boring......

Then, i'm trying again with fedora 8, but i don't think that it'll change this strange behavior....-.-
I'm afraid to tell you that there's nothing wrong with babel, there's something wrong with your ssh.

If you don't get it running and you don't wanna spend more time on that issue, you might want to try FTP out instead to transfer de XML.

The problem with the libraries are totally normal as Babel need some stuff to run, you know :-)
You have to install the following packages:

Hope this helps

Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes