Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error starting /etc/init.d/pandora_server service
Hello everybody I´m installing Pandora FMS server, but at moment to start the pandora_server service, it show thist error:

[[email protected] admin]# /etc/init.d/pandora_server start
Can't locate NetAddr/ in @INC (@INC contains: /usr/lib/perl5/5.10.0 /usr/lib/perl5 /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/share/perl5 .) at /usr/lib/perl5/PandoraFMS/ line 28.
BEGIN failed--compilation aborted at /usr/lib/perl5/PandoraFMS/ line 28.
Compilation failed in require at /usr/bin/pandora_server line 35.
BEGIN failed--compilation aborted at /usr/bin/pandora_server line 35.
Cannot start Pandora FMS Server. Aborted.
Check Pandora FMS log files at '/var/log/pandora/pandora_server.error & pandora_server.log'

I were trying to see the logs, but the pandora_server.log and pandora_server.error files don´t exists.

Help me please.
Hello everybody....

I just solved this trouble. Verifying step by step the instalation proccess, I remebered that installing CPAN modules an error ocurred and I got an error:

"Warning (usually harmless): 'YAML' not installed, will not store persistent state
> Running make test
>  Can't test without successful make
> Running make install
>  Make had returned bad status, install seems impossible"

Searching in google, I read a post where mentioned "install force" in CPAN shell, and was what that I did.

I introduce like root
CPAN> install force Digest::MD5 Time::Local DBI threads threads:Confusedhared IO::Socket Time::HiRes Time::Format NetAddr::IP Mail::Sendmail Net::Traceroute::PurePerl HTML::Entities

and !!!!it worked!!!!
Hi to all,
I have install Pandora FMS v4.0.1 and in the moment I launch pandora_server start, it return the error message:

[email protected]:/etc/init.d# pandora_server start

Pandora FMS Server 4.0.1 Build 111220 Copyright © 2004-2011 ArticaST
This program is OpenSource, licensed under the terms of GPL License version 2.
You can download latest versions and documentation at

[ERROR] Cannot open configuration file at start.
Please specify a valid Pandora FMS configuration file in command line.
Standard configuration file is at /etc/pandora/pandora_server.conf

What I have to do?


Could you check the permissions of file or exist?

This file normally have a permissions:
640 root root


The problem you have is when you start the service.

If you are inside "/etc/init.d/"

[email protected]:/etc/init.d#

you should start with "./" before "pandora_server start"

try it like this

[email protected]:/etc/init.d#./pandora_server start

See this topic, it has th same issue (in spanish) :,5478.0.html


Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes