Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WMI - non initialised module
I'm trying to setup an agent to use the CPU load module to check the load on the CPU on a Windows XP SP3 workstation on a domain that I have administrative access too.  I thought it would be easy.

The problem is after I setup the module and update it under the serer tab there are two icons.  One says "Pandora FMS WMI Server" and the other says "non initialised module".  One thing I have to mention is the query that's in the module won't work in the command-prompt.  For example the module query is [SELECT LoadPercentage from Win32_Processor WHERE DeviceID = "CPU0"].  When I run the query through the command prompt I have to wrap the whole thing in quotes and put the CPU0 in single quotes(').  Here is the example that works in the command prompt ["SELECT LoadPercentage from Win32_Processor WHERE DeviceID = CPU0'"].

The last thing I noticed is in the command prompt between the domain and user (when using wmic -U) i have to put two slashes (\\).  For example "domain\\user%password" is what works.

I've tried all combinations in the module and still get the same results.  As an FYI i'm using Ubuntu 10.04.1.  If I install the agent on the machine it reports to Pandora just fine, other ICMP checks work fine as well.

I have attached a screenshot of my module and agent modules.

Thank you in advance!

Attached Files

.png   agent.png (Size: 16.57 KB / Downloads: 357)
.png   Module.png (Size: 48.53 KB / Downloads: 401)
Hi nickohyzer,

  Try to log in your pandora server, and run "wmic" from the command line. See if your command works using the wmic. If it's not working in command prompt, it will not work in pandora...

Hope this helps.



Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes