Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem adding Perl-Net::Ping::External module
Good Morning:

I was trying to add some Perl Modules required for installing Pandora FMS 1.2 in a computer with Red Hat Enterprise Linux v. 4 update 4, but trying to do it with cpan shell I’ve found a trouble with Net::Ping::External module.

In fact, I don’t understand the reason of this issue, but I also must admit I am a beginner in this subject. Could you help me with the installation of this module? Is it really necessary for Pandora running fine? I’d really appreciate if you could give me some advice.

I attach you a part of the output of the command. Tell me if you need more info:

cpan> install Net::Ping::External

Running a more verbose test suite.

Net::Ping::External version: 0.12
5/6 tests passed.

Successful tests:
use Net::Ping::External qw(ping)
ping(host => '')
ping(host => '', timeout => 5)
ping(host => '', count => 10)
ping(host => '', size => 32)

Failed tests:
ping(host => '')

Usage: ping [-LRUbdfnqrvVaA] [-c count] [-i interval] [-w deadline]
[-p pattern] [-s packetsize] [-t ttl] [-I interface or address]
[-M mtu discovery hint] [-S sndbuf]
[ -T timestamp option ] [ -Q tos ] [hop1 ...] destination

Operating system according to perl: Operating system according to `uname -a` (if available):

Linux localhost.localdomain 2.6.9-55.ELsmp #1 SMP Fri Apr 20 17:03:35 EDT 2007 i686 i686 i386 GNU/Linux

Perl version: This is perl, v5.8.5 built for i386-linux-thread-multi

Ping help:

Tests: fail

make: *** [test_dynamic] Error 1

/usr/bin/make test -- NOT OK

Running make install

make test had returned bad status, won't install without force

Thanks in advance.
As in the other thread....

What's the error pandora's complaining about?
Thank you for your quick answer, manu.

The issue is that a needed perl module (Net::Ping::External ) cannot be added (regarding the INSTALL file). As it shows in the output during the adding process of this module:

Tests: fail
make: *** [test_dynamic] Error 1
/usr/bin/make test -- NOT OK
Running make install
make test had returned bad status, won't install without force
What about installing perl-Net-Ping-External by using its RPM and not the sources?
I installed sources because I was looking for that rpm and I didn't find it (RHEL didn't contain it). And looking for some help in Internet, appeared this way as a good one. I did the same with other modules and worked fine (except SNMP one).
Ummm as long as Fedora do contain it, RHEL must have one similar:

[[email protected] ~]# rpm -qa | grep -i perl-Net-Ping

Furthermore, I have the RPM here, do you want me to send it to you?
If so, leave me your email.

Good night:

I am sorry for the delay in my answer. Your solution worked fine, and the problem adding this perl module was solved.

Tank you, Manu.

Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes