Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No detecta algunos dispositivos
#1
Buenos días,

Soy nuevo utilizando el software de PandoraFMS y además no soy un genio en Linux.
Dicho esto, estoy buscando ayuda a la hora de empezar con Pandora.

He realizado un task para escanear toda mi red, y ha encontrado bastantes dispositivos, los cuales ya he organizado, pero no todos y no entiendo el por qué..

Entre los dispositivos que no ha encontrado, por ejemplo, estan los routers mikrotik.  He probado a hacerles ping desde la consola y no llega, cuando estan exactamente en el mismo segmento de red que el servidor de pandora (última version con CentOS).

Para descartar, los Mikrotik no tienen capado el ping, desde cualquier cliente o cualquier otro servidor en esa red le puedo hacer ping correctamente, pero desde Pandora no.
Sin embargo, desde el router al servidor de Pandora si que llega y responde correctamente.

Probé también a activar el SNMP en los mikrotik, pero tampoco llega mediante SNMP.

Además de los Mikrotik me pasa esto con algún otro dispositivo como Switches, alguna cámara y algún otro servidor.. No entiendo porque algunos si y otros no..

Si me pudieran echar una mano...

Gracias, un saludo.
 Reply
#2
¡Hola!

Os recomiendo este artículo que he escrito (digo yo) de forma amena y buscando la mayor simplicidad posible para llevar el enfoque de la monitorización de puertos:

https://pandorafms.com/blog/es/monitoriz...e-puertos/

Sí, ya se lo que diréis: ping no usa puertos... Leed que allí hay tela para cortar. En cuanto a lo del ping pues me habeis pillado en una "discusión" con mi jefe de operaciones, a él le encanta jugar en línea (cómo escaquea el hombre)  y donde estamos hemos tenido problemas serios de latencia (que los monitorizamos con ping). Si logro aprender algo nuevo os lo publico por acá, gracias por vuestra atención.

Postdata:

revisad esto si vuestro Mikrotik utiliza RouterOS:

https://help.mikrotik.com/docs/display/R...g-MAC-Ping

esta instrucción:

Code:
/tool mac-server ping print
 Reply
#3
Buenos días Jimmy,

Te agradezco la respuesta, leí la entrada en el blog y es interesante, pero no me ayuda con mi problemática.

Mi Mikrotik si utiliza RouterOS y comprobé que la instruccion indicada está como enable.
Aún así ya descartaba que el ping estuviera deshabilitado, porque como comenté desde otros servidores o workstations los ping llegan y responden correctamente.

Es simplemente desde Pandora desde donde no puedo hacer ping, como consecuencia no puedo utilzar el Host Alive ni el Host Latency para la monitorización de este dispositivo.

Destacar además que en sentido inverso, desde el Mikrotik hacia el pandora realizo los ping satisfactoriamente.
 Reply
#4
Interesante lo del RouterOS, estoy tratando de hacer memoria, creo haberlo visto antes.

Cuando saque tiempo os cuento si logro algo, mientras tanto estuve toqueteando en el demo de la página web y es un buen campo de juego, ¡claro está, la vida real con un dispositivo de verdad es lo valedero!
 Reply
#5
Buenas!

Es un error raro el que mencionas, entiendo que se debe originar en alguna proteccion que tendran tus dispositivos ante pings constantes o algo similar, pero nunca he trabajado con estos routers que mencionas, por lo que no puedo ayudarte mas en ese sentido. Si pandora esta monitorizando correctamente el resto de dispositivos pero tiene problemas con alguno concreto es por que esta siendo bloqueado por dicho equipo (o al menos eso es lo que veo mas probable en este caso).

En cualquier caso, si el problema se origina solo en la conexión Servidor de Pandora > Router mi consejo seria instalar un agente software en el router, de esta forma podrás monitorizarlo sin problemas, ya que sera el agente software del router el que se encargue de mandar la información, sin necesidad de que Pandora haga nada que no sea procesar la información recibida.

Te dejo un enlace a la wiki de Pandora para que veas como instalarlo. Si tienes mas problemas, no dudes en preguntar.

https://pandorafms.com/docs/index.php?ti...andora_FMS

Saludos
Diego
 Reply
#6
Buenos días

Hice la prueba de dejar durante una noche haciendo ping desde un cliente windows (mi laptop) hacía el router mikrotik, constante y con carga, y no ha fallado, por lo cual descarto la "protección" posible que pudiera tener como comentas.

"Ping x.x.x.x -l 1024 -t"

Además de a estos dispositivos Mikrotik, me pasa también con todos los routers que tengo de distintas marcas, Linksys por ejemplo... y con algunas cámaras de videovigilancia y algunos switchs..

Respecto a lo de instalar el agente software en el router, no he entendido como hacerlo, de hecho no se si se podrá..
He revisado el enlace que me has mandado, pero no entiendo como debería hacerlo.
 Reply


Users browsing this thread: 2 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes