Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem during installation CREATING DATABASE
I have been trying to install Pandora Community in Centos 7, but I can't get step 6 because I got problems during the creation of the Database.

  A) On the 4th step, when I set "Installation in: a new Database":
     I got this error "There were some problems. Installation was not completed":
        printscreen attached Try1
  B) On the second try, I previously created the pandora database in Mysql. On the 4th step, I set "Installation in: a new Database":
     I got again the same error with more information on the screen.
        printscreen attached Try2
     I used this url to install the open source version.
  This is some data about my environment:
      - CentOS Linux release 7.7.1908 (Core)
      - SELinux is disabled, I executed this command "sudo setenforce 0"
      - Mysql 8.0.19 
      - pandorafms_server and pandorafms_console versión: 7.0NG.744

  I searched and applied different solutions from forums on the Internet, but they didn't work.

  I have already config /etc/my.cnf with this:
     I confirmed this setting is working from mysql with these command:
         mysql> SELECT @@GLOBAL.sql_mode;
     I got the expected value NO_ENGINE_SUBSTITUTION

  Additionally, I checked that I don't have any validation password. I tried these commands:
    > uninstall plugin validate_password;  
       I got the message "ERROR 1305 (42000): PLUGIN validate_password does not exist"
    > UNINSTALL COMPONENT 'file://component_validate_password';
       I got this message "ERROR 3537 (HY000): Component specified by URN 'file://component_validate_password' to unload has not been loaded before."
    > CREATE USER [email protected] IDENTIFIED BY 'user123';
       It was successful. I could create an user with an easy password

  I checked all these files, but I didn't find any error at the time I tried to install.

     >cat /var/log/pandora/pandora_server.log
     >cat /var/log/pandora/pandora_server.error
     >cat /var/log/pandora/pandora_agent.log. There isn't.
     >cat /var/www/html/pandora_console/pandora_console.log. There isn't.
     >cat /var/log/httpd/error_log
     >cat /var/log/messages
     >cat /var/log/pandora/pandora_snmptrap.log
     >cat /var/log/mysqld.log
  I don't know what else to do.

  Please, your help

Attached Files

.png   ErrorPandoraInstallationTry1.PNG (Size: 19.15 KB / Downloads: 2)
.png   ErrorPandoraInstallationTry2.png (Size: 66.5 KB / Downloads: 2)
I could finish the installation with de option existing database. I ignored the errors, and I created the tables and data manually with these sentences.

mysql -u root -p pandora < /var/www/html/pandora_console/pandoradb.sql
mysql -u root -p pandora < /var/www/html/pandora_console/pandoradb_data.sql

After that you have to rename install.php manually.

Finally, you can access to the site http://ipaddress/pandora_console

In my case, I had problems with the connection to the database because the  php-mysql client doesn't support the new hash autentication method of mysql 8.

It was solved updating the pandora user

ALTER USER [email protected] IDENTIFIED WITH mysql_native_password BY 'myPassword';

Currently pandora fms doesn't support mysql 8 version, but i'm glad you found a solution to this problem, that will help many other users.


Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes