Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problems with Phantomjs on CentOS 7
#1
Hi,

I've installed Pandora 7.28 on CentOS 7x64 with MySQL 5.724 and works fine, but when I try to install Phantom Extension using Pandora Guide 

https://wiki.pandorafms.com/index.php?ti...#Phantomjs

Pandora Server all the time sais that i need to install phantomjs... 

I put user root.root and apache.apache in folder phantomjs but always sais the same, is not installed, any idea?

Code:
[[email protected] opt]# ll
total 2647400
-rwxr-x---. 1 root   root        15080 oct  2  2017 epel-release-latest-7.noarch.rpm
lrwxrwxrwx  1 mysql  mysql          35 nov  7 11:32 mysql -> mysql-5.7.24-linux-glibc2.12-x86_64
drwxr-xr-x  9 root   root          129 nov  7 11:31 mysql-5.7.24-linux-glibc2.12-x86_64
-rw-r--r--  1 root   root    644930593 oct  4 06:28 mysql-5.7.24-linux-glibc2.12-x86_64.tar.gz
drwxr-x---. 9 mysql  mysql         172 nov  6 14:53 mysql-8.0.13-linux-glibc2.12-x86_64
-rwxr-x---. 1 root   root   2042695680 oct  8 09:55 mysql-8.0.13-linux-glibc2.12-x86_64.tar
drwxr-xr-x  3 apache apache         17 nov  6 16:52 phantomjs
-rw-r--r--  1 root   root     23415665 ene 25  2016 phantomjs-2.1.1-linux-x86_64.tar.bz2
[[email protected] opt]# ll phantomjs
total 0
drwxr-xr-x 2 apache apache 23 nov  6 16:53 bin
[[email protected] opt]# ll phantomjs/bin/
total 66340
-rwxr-xr-x 1 apache apache 67932064 jun 12 14:51 phantomjs[[email protected] opt]#
[[email protected] opt]#


[[email protected] opt]# cat /root/.bash_profile
# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi

# User specific environment and startup programs

PATH=$PATH:$HOME/bin:/opt/mysql/bin:/opt/phantomjs/bin

export PATH


[[email protected] opt]# ll /usr/bin/phantomjs
lrwxrwxrwx 1 root root 28 nov  6 16:53 /usr/bin/phantomjs -> /opt/phantomjs/bin/phantomjs
[[email protected] opt]#


[Image: 0NmzTZu.png]
 Reply
#2
(11-07-2018, 02:31 PM)gairhald Wrote: Hi,

I've installed Pandora 7.28 on CentOS 7x64 with MySQL 5.724 and works fine, but when I try to install Phantom Extension using Pandora Guide 

https://wiki.pandorafms.com/index.php?ti...#Phantomjs

Pandora Server all the time sais that i need to install phantomjs... 

I put user root.root and apache.apache in folder phantomjs but always sais the same, is not installed, any idea?

Code:
[[email protected] opt]# ll
total 2647400
-rwxr-x---. 1 root   root        15080 oct  2  2017 epel-release-latest-7.noarch.rpm
lrwxrwxrwx  1 mysql  mysql          35 nov  7 11:32 mysql -> mysql-5.7.24-linux-glibc2.12-x86_64
drwxr-xr-x  9 root   root          129 nov  7 11:31 mysql-5.7.24-linux-glibc2.12-x86_64
-rw-r--r--  1 root   root    644930593 oct  4 06:28 mysql-5.7.24-linux-glibc2.12-x86_64.tar.gz
drwxr-x---. 9 mysql  mysql         172 nov  6 14:53 mysql-8.0.13-linux-glibc2.12-x86_64
-rwxr-x---. 1 root   root   2042695680 oct  8 09:55 mysql-8.0.13-linux-glibc2.12-x86_64.tar
drwxr-xr-x  3 apache apache         17 nov  6 16:52 phantomjs
-rw-r--r--  1 root   root     23415665 ene 25  2016 phantomjs-2.1.1-linux-x86_64.tar.bz2
[[email protected] opt]# ll phantomjs
total 0
drwxr-xr-x 2 apache apache 23 nov  6 16:53 bin
[[email protected] opt]# ll phantomjs/bin/
total 66340
-rwxr-xr-x 1 apache apache 67932064 jun 12 14:51 phantomjs[[email protected] opt]#
[[email protected] opt]#


[[email protected] opt]# cat /root/.bash_profile
# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
        . ~/.bashrc
fi

# User specific environment and startup programs

PATH=$PATH:$HOME/bin:/opt/mysql/bin:/opt/phantomjs/bin

export PATH


[[email protected] opt]# ll /usr/bin/phantomjs
lrwxrwxrwx 1 root root 28 nov  6 16:53 /usr/bin/phantomjs -> /opt/phantomjs/bin/phantomjs
[[email protected] opt]#


[Image: 0NmzTZu.png]

Good morning gairhald,

Can you please tell me what memory do you have? Phantomjs requieres plenty of memory for its use and that may be the problem.

If not, try to use the command: phantomjs and it should enter you to the Phantomjs execution mode. Also you need to setup the PATH in the setup in "Phantomjs bin directory[Image: tip.png]"

Please try all these things and tell us the result.

Alberto
 Reply
#3
(11-08-2018, 10:04 AM)alberto.sanchez Wrote: Good morning gairhald,
Can you please tell me what memory do you have? Phantomjs requieres plenty of memory for its use and that may be the problem.

If not, try to use the command: phantomjs and it should enter you to the Phantomjs execution mode. Also you need to setup the PATH in the setup in "Phantomjs bin directory[Image: tip.png]"

Please try all these things and tell us the result.

Alberto

hi Alberto,

Pandora server has 4GB and 2.7 free, and Phantom is in the path, need more RAM?



Code:
[[email protected] ~]# free -kh
              total        used        free      shared  buff/cache   available
Mem:           3,7G        581M        2,7G         11M        471M        2,9G
Swap:          4,2G          0B        4,2G
[[email protected] ~]# phantomjs
phantomjs>
phantomjs>
phantomjs> ?
Unexpected token '?'

  phantomjs://repl-input:1 in global code
phantomjs> exit
Can't find variable: exit

  phantomjs://repl-input:1 in global code
phantomjs> quit
Can't find variable: quit

  phantomjs://repl-input:1 in global code
phantomjs>
[[email protected] ~]#
 Reply
#4
(11-08-2018, 11:34 AM)gairhald Wrote:
(11-08-2018, 10:04 AM)alberto.sanchez Wrote: Good morning gairhald,
Can you please tell me what memory do you have? Phantomjs requieres plenty of memory for its use and that may be the problem.

If not, try to use the command: phantomjs and it should enter you to the Phantomjs execution mode. Also you need to setup the PATH in the setup in "Phantomjs bin directory[Image: tip.png]"

Please try all these things and tell us the result.

Alberto

hi Alberto,

Pandora server has 4GB and 2.7 free, and Phantom is in the path, need more RAM?



Code:
[[email protected] ~]# free -kh
              total        used        free      shared  buff/cache   available
Mem:           3,7G        581M        2,7G         11M        471M        2,9G
Swap:          4,2G          0B        4,2G
[[email protected] ~]# phantomjs
phantomjs>
phantomjs>
phantomjs> ?
Unexpected token '?'

  phantomjs://repl-input:1 in global code
phantomjs> exit
Can't find variable: exit

  phantomjs://repl-input:1 in global code
phantomjs> quit
Can't find variable: quit

  phantomjs://repl-input:1 in global code
phantomjs>
[[email protected] ~]#

Good morning gairhald,

Please try to save a report as PDF to see if the phatomjs is working at least. Some other problems can be:

1) That you haven't put the execution privilege to the phantomjs.
2) Try to click again on update in the setup, can be caused that the variable has not been saved into the database
3) Try to delete the cache data.

Please do all these things and tell us more about it.

Alberto
 Reply
#5
(11-13-2018, 08:29 AM)alberto.sanchez Wrote:
(11-08-2018, 11:34 AM)gairhald Wrote:
(11-08-2018, 10:04 AM)alberto.sanchez Wrote: Good morning gairhald,
Can you please tell me what memory do you have? Phantomjs requieres plenty of memory for its use and that may be the problem.

If not, try to use the command: phantomjs and it should enter you to the Phantomjs execution mode. Also you need to setup the PATH in the setup in "Phantomjs bin directory[Image: tip.png]"

Please try all these things and tell us the result.

Alberto

hi Alberto,

Pandora server has 4GB and 2.7 free, and Phantom is in the path, need more RAM?



Code:
[[email protected] ~]# free -kh
              total        used        free      shared  buff/cache   available
Mem:           3,7G        581M        2,7G         11M        471M        2,9G
Swap:          4,2G          0B        4,2G
[[email protected] ~]# phantomjs
phantomjs>
phantomjs>
phantomjs> ?
Unexpected token '?'

  phantomjs://repl-input:1 in global code
phantomjs> exit
Can't find variable: exit

  phantomjs://repl-input:1 in global code
phantomjs> quit
Can't find variable: quit

  phantomjs://repl-input:1 in global code
phantomjs>
[[email protected] ~]#

Good morning gairhald,

Please try to save a report as PDF to see if the phatomjs is working at least. Some other problems can be:

1) That you haven't put the execution privilege to the phantomjs.
2) Try to click again on update in the setup, can be caused that the variable has not been saved into the database
3) Try to delete the cache data.

Please do all these things and tell us more about it.

Alberto

sorry, i was holidays, the phamtomjs folder is in execution, the second part i don't understand, where i do click update?? update manager in pandora console? I updated it and nothing :/

but hey, don't worry, I do not think he uses the reports, thank you
 Reply
#6
Did you ever get this issue sorted? I'm having exactly the same problem.

As per the instructions in this documentation I installed phantomjs in /opt/phantomjs/bin and created a symlink /usr/bin/

I have tried setting the "Phantomjs bin directory" to both /opt/phantomjs/bin and /usr/bin, I have confirmed that the file is executable, I have even changed the owner and group to apache:apache as I noted the part that said "The user providing the web pages (by default Apache) should be able to run this file in the selected location."

I have deleted cached data and restarted the server several times and I just can't get this working. Please can someone help?
 Reply
#7
(01-21-2019, 04:54 PM)AWBbox Wrote: Did you ever get this issue sorted? I'm having exactly the same problem.

As per the instructions in this documentation I installed phantomjs in /opt/phantomjs/bin and created a symlink /usr/bin/

I have tried setting the "Phantomjs bin directory" to both /opt/phantomjs/bin and /usr/bin, I have confirmed that the file is executable, I have even changed the owner and group to apache:apache as I noted the part that said "The user providing the web pages (by default Apache) should be able to run this file in the selected location."

I have deleted cached data and restarted the server several times and I just can't get this working. Please can someone help?

Good morning AWBbox,

We are trying to solve this issue of the warning when Phantomjs is installed. However, for the OpenSource Phantomjs is not really needed for the reports.

Alberto
 Reply
#8
(01-22-2019, 08:56 AM)alberto.sanchez Wrote: Good morning AWBbox,

We are trying to solve this issue of the warning when Phantomjs is installed. However, for the OpenSource Phantomjs is not really needed for the reports.

Alberto

Hi Alberto,

Many thanks for confirming, I was mainly hoping to get rid of the warning as it was annoying. Glad to hear it's a known issue.
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes