Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problemas con el módulo Keep_alive
#1
Hola a todos,

Tengo un servidor Pandora versión 2.1, y agentes en los servidores que monitorizo con la versión 2.0.

En uno de los agentes, tengo varios módulos asignados, todos ellos aprendidos automáticamente desde el agente remoto.

He añadido un módulo de datos extra, de tipo keep_alive.

Según lo que he entendido leyendo la documentación, cuando no se reciben datos de ninguno de los módulos en un periodo igual a dos veces el intervalo del agente, este módulo debería pasar a 0.

Para probarlo, he parado el agente de pandora en el servidor remoto que monitorizo. En ese momento, mi servidor Pandora deja de recibir los datos de los módulos, pero el módulo keepalive, no se entera, y sigue reportando valor de 1, por lo que nunca me llega a saltar la alerta.

He esperado 1 hora, y el módulo keepalive sigue tal cual.

Alguien me puede echar un cable? Qué puede estar pasando?

Gracias de antemano,

Un saludo
 Reply
#2
buenas,

¿como lo has configurado? yo tengo pandora 3.0 y agentes de distintas versiones en distintas máquinas y me fucniona bien.

Lo que yo hice en pandora 3.0:

Gestionar agentes - eliges el agente - modulos - crear nuevo modulo de servidor de datos -
nombre: agent_keepalive
estado advertencia: min:0 max:1
intervalo:300

hay que reiniciar el agente para que lo coja. Algunos tuve que reiciar el server también.

Suerte
 Reply
#3
Hola.

Tengo también problemas con este modulo, en algunos agentes puedo agregar el modulo keepalive, peo en otros no.

Eh reiniciado el agente como el Servidor pero persiste el problema que podría ser ?

Gracias.
 Reply
#4
Hola Borjagb,

Lo he configurado exáctamente como has hecho tú. He reiniciado el agente varias veces. Lo que no he hecho ha sido reinciar el servidor Pandora, pero entiendo que no debería ser necesario.

Alguna otra pista? Se supone que con añadir este módulo, en cuanto el resto de los módulos dejen de reportar datos, debería saltar y ponerse a cero este monitor, no? Luego ya si le asocias alertas, pues saldrán las alertas, pero es que mi módulo sigue tal cual, con un 1 y no se entera!!!

GRacias
 Reply
#5
Buenas,

el modulo funciona de manera que en cuanto el agente al que hayas añadido este modulo deje de enviar dator por un periodo de 10/15 minutos se pone a 0. ¿has comprobado que al deter el agente no hay creados otros agentes en ese servidor? Prueba a parar el agente y lanzar un ps -ef para comprobar que no sigue corriendo. despues espera 15m a ver si se pone a 0 el modulo.

No puedo ayudarte mucho más ya que no llevo mucho tiempo usando pandora.

suerte
 Reply


Users browsing this thread: 2 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes