Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No module connection
I am using the openSuSE Pandora VMImage. Great thing! But... I cannot get a connection to a modules server. I can add a ICMP check module, or an NIC#1 Status module, this is all working for the server. But when I add an already defined module to the agent, it won´t initialize. The client-agent is working perfectly, there is a network connection, but the server can´t see the agent service.

First I thought there is a firewall active on the server, but it´s off by default...
Looks like a communication problem between pandora server and the monitored agents..

Are you using tentacle? Have you tried ssh between the hosts? Are they at different networks?
I learned much about the process between agent and server yesterday. It seems as if the agent is unable zu transfer the datafile into the server´s data_in folder. But I don´t have an explanation why.

I had a standalone test-server last week where it worked perfectly. After that I used the ready-to-start VMWare image from this site, reinstalled the agent and since then it doesn´t work anymore. I tried a self-made Debian VMWare install but still it doesn´t work.

I used SSH instead but still no luck. I also tested the connection with SSH over the script command, it says "file copied succesfully"... either the file cannot be transfered or the file is never created...
I can see another thing happening here:

Pandora log says "Unable to copy at /var/spool/pandora/data_in/"


the pandoraagent with parameter --test-ssh says "succesful copied testfile"

Sounds like a permission problem somewhere... hmmmm...
Check if the tentacle service is up and running at pandora server.

Tentacle is much easier to set up than ssh, but if you need, I can help you with ssh setup.
I'm having exactly the same problem (--test-ssh is successful but still I get "Unable to copy at /var/spool/pandora/data_in/").

JPSelter: were you able to solve the issue?
Check the permissions of the .ssh folder and from the authorized_keys file. It MUST be:

700 for .ssh
640 for authorized_keys

Hope this helps. Regards.
Apparently there's nothing wrong with copying the files to the server. The files are transferred fine and pandora server processes them.

But still: all pandora agents' log files are getting filled with these kinds of messages:

2010-04-01 10:36:06 Unable to copy at /var/spool/pandora/data_in/

What the heck? What's the error message for if everything is working..?

Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes