Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with server and installed perl
#1
Hi,

today I liked to play a little bit with PandoraFMS, so I decided to install it on one of my test servers. This is a solaris 10 sparc 64 server with an updated perl (v5.8.8).
Everything went fine, except the startup of the "/usr/bin/pandora_server start":


/opt/imperia_perl/current/lib/perl5/site_perl/5.8.8/PandoraFMS/DataServer.pm line 23:

This Perl hasn't been configured and built properly for the threads
module to work.  (The 'useithreads' configuration option hasn't been used.)

Having threads support requires all of Perl and all of the XS modules in
the Perl installation to be rebuilt, it is not just a question of adding
the threads module.  (In other words, threaded and non-threaded Perls
are binary incompatible.)

If you want to the use the threads module, please contact the people
who built your Perl.

Cannot continue, aborting.
BEGIN failed--compilation aborted at /opt/imperia_perl/current/lib/perl5/5.8.8/sun4-solaris/threads.pm line 28.
Compilation failed in require at /opt/imperia_perl/current/lib/perl5/site_perl/5.8.8/PandoraFMS/DataServer.pm line 23.
BEGIN failed--compilation aborted at /opt/imperia_perl/current/lib/perl5/site_perl/5.8.8/PandoraFMS/DataServer.pm line 23.
Compilation failed in require at /usr/bin/pandora_server line 32.
BEGIN failed--compilation aborted at /usr/bin/pandora_server line 32.
zaszbv6:/etc/pandora

What should I do now? Google and the forum search did not helped me...

Thanks,

Chriss
 Reply
#2
Hi,

I solved the issue... I installed a new perl version into a other dir with threading support.

thanks,

Chriss
 Reply
#3
(02-22-2010, 01:52 PM)Chriss link Wrote: Hi,

I solved the issue... I installed a new perl version into a other dir with threading support.

thanks,

Chriss

Thanx for posting your self the solution. This happen in some systems with a non-threaded version of Perl, like your Solaris and like Gentoo Linux, for example.

I hope everything is fine now, are you running also the console under Solaris, any problem ?. We don't have many users running under different OS than linux (a few users in BSD and Solaris only).
 Reply
#4
Hi,

the situation is bad enough. Wink

I still have some problems with the suite on solaris. The Console reportet an error on top of every page. This is solved, I removed the code from the php. Since then, nearly all icons are shown in the console.
There is an unsolved issue with the popups: If I click on a graph the popup opens but I do not se any graphs, one the "summery" like: Max. Value: 94 Avg. Value: 4.0 Min. Value: 0

The next issue are all the scripts... you are using "grep -e" this is a GNU feature and not supportet in solaris. Sad The solution is to change all the sripts from grep to /usr/xpg4/bin/grep from SUNWxcu4, ore change $PATH, anyway you will need to install SUNWxcu4. 

And one more thing, the installer sript for the server is not working. The installer script terminated with an "ERROR compiling Pandora FMS Server from sources. Aborting", this is solved with an installation by hand.
The last problem is graphviz, till now I found no way to compile and install it on solaris. This looks like I'm sissing to mutch libs. Here is still work in procress.... Wink This my fix my problems with the graphs... hopefully.. Wink


The agend installation whas not a big deal, it looks like an easy thing. But this is a installation on localhost first... So more problems may show up later.



Thanks,

Chriss
 Reply
#5
I found an open tap with the error message from the console:
Notice: Use of undefined constant E_DEPRECATED - assumed 'E_DEPRECATED' in /opt/pandora/include/config_process.php on line 34

Can somebody fix that? Smile I just removed the line from the config_process.php
 Reply
#6
If you can arrange a Solaris script for install, it could be included in future versions, just put here.

About the graphwiz, don't worry too much, it's used only to generate the fancy realtime network graphs.

Errors in console could be "masked" editing some code in include/config_process.php setting
variable $develop_bypass = 1 to avoid development debug messages like you say.

Problem with graphs could be related with an unsolved PHP dependency like PHP-gd

Good luck !

(03-02-2010, 02:06 PM)Chriss link Wrote: Hi,

the situation is bad enough. Wink

I still have some problems with the suite on solaris. The Console reportet an error on top of every page. This is solved, I removed the code from the php. Since then, nearly all icons are shown in the console.
There is an unsolved issue with the popups: If I click on a graph the popup opens but I do not se any graphs, one the "summery" like: Max. Value: 94 Avg. Value: 4.0 Min. Value: 0

The next issue are all the scripts... you are using "grep -e" this is a GNU feature and not supportet in solaris. Sad The solution is to change all the sripts from grep to /usr/xpg4/bin/grep from SUNWxcu4, ore change $PATH, anyway you will need to install SUNWxcu4. 

And one more thing, the installer sript for the server is not working. The installer script terminated with an "ERROR compiling Pandora FMS Server from sources. Aborting", this is solved with an installation by hand.
The last problem is graphviz, till now I found no way to compile and install it on solaris. This looks like I'm sissing to mutch libs. Here is still work in procress.... Wink This my fix my problems with the graphs... hopefully.. Wink


The agend installation whas not a big deal, it looks like an easy thing. But this is a installation on localhost first... So more problems may show up later.



Thanks,

Chriss
 Reply


Users browsing this thread: 5 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes