Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FMS 3.0: Email not sent
#1
I have created an action with command "email" and filled out all 3 fields (mail adress / subject / body). Then I created a template, added the action to it, here I also filled out all 3 fields. Then I connected the template to one of my hosts. The alert fires but no email is sent.

I used the EXPECT approach, from the command line I can send a test message with "smtp [email protected] Test Text", this works ok, no matter with what user or from where I start the script. So there seems to be no permission issue.

But what could it be? I cannot edit the default command "Email". What does it do exactly?

Thanks for any help!
 Reply
#2
I solved it myself... I created a new command where I put the "smtp _field1_ _field2_ _field3" command in.

Buuuuut... there seems to be a little bug: I´m not allowed to use spaces in field2... so

smtp "myadress" "Host is down" "Text"

is converted into

smtp "myadress" "Host" "is"

What´s happening here?
 Reply
#3
As you say, this could be a bug, that filed2 is not allowing spaces. Could you add the bug to our tracker:

http://sourceforge.net/tracker/?func=add...tid=794852

Thanks
 Reply
#4
Is done. I wonder how other users send their alert emails, I can´t seriously be the first who notices this nasty little bugger ;-)
 Reply
#5
I finished my traumatic migration process from version 2.1 this week and configured alerts with the internal eMail command... Everything worked quite well...

I only had to add the mta_from line in the /etc/pandora/pandora_server.conf file:

mta_from: [email protected]
 Reply
#6
Should be:

mta_from  [email protected]

Beware of the extra ":" dots. I'm going to remove from the sample conf to avoid future confussions.

(03-18-2010, 05:19 PM)daniels link Wrote: I finished my traumatic migration process from version 2.1 this week and configured alerts with the internal eMail command... Everything worked quite well...

I only had to add the mta_from line in the /etc/pandora/pandora_server.conf file:

mta_from: [email protected]
 Reply
#7
can anyone put a "real" script to use expect or all the steps to make it works (changes in pandora_server.conf, in commads...)


thanks!
 Reply


Users browsing this thread: 1 Guest(s)


(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | pandorafms.com | pandorafms.org

Theme © MyBB Themes