Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Solved] flash graph is not working
Nothing happens, the problem remains.

Thanks for your help.

This is my screen,

Attached Files

.png   Pantallazo.png (Size: 172.54 KB / Downloads: 194)
My case SOLVED.

You were wright. I compared the actual version with the old one (2.1) and I discovered some difference in the configuration of the file ./include/config.php.

The configuration which does work is:

// Begin of automatic config file
$config["dbname"]="pandora";                    // MySQL DataBase name
$config["dbuser"]="root";                      // DB User
$config["dbpass"]="pandora";                    // DB Password
$config["dbhost"]="localhost";                  // DB Host
$config["homedir"]="/var/www/pandora_console";          // Config homedir
$config["homeurl"]="/pandora_console";                  // Base URL
// End of automatic config file

I changed it, and all the graphics are working.
As I see in the picture you have sent, you have your url in /pandora_console, so you should have in your config file:


Anyway, if you take a look at the source code of the HTML page in the graph page, and search for FusionCharts, what do you see?

By the way, I'm from Salamanca :-D

(01-19-2010, 08:22 AM)nachocharro link Wrote: Nothing happens, the problem remains.

Thanks for your help.

This is my screen,
You're right in the two things,

FusionChart is referred to pandora_console

<script language="JavaScript" src="/pandora_console/include/FusionCharts/FusionCharts.js"></script>

and I'm from Salamanca too.

All is working now, better than ever.
Quote:var myChart = new FusionCharts("' .    $pre_url .  '/include/FusionCharts/FCF_MSArea2D.swf",

fixed our problem.

(01-18-2010, 05:50 PM)raul link Wrote: Mmm, I think it's a bug. It should be solved in one commit.

Let's try to solve it:

Change the code in the /include/functions_fsgraph.php file, line 195, from:

[sup]var myChart = new FusionCharts("' .   $config["homeurl"] .  '/include/FusionCharts/FCF_MSArea2D.swf",[/sup]


[sup]var myChart = new FusionCharts("' .     $pre_url .  '/include/FusionCharts/FCF_MSArea2D.swf", [/sup]

Please, change, and try again.



Just wanted to throw in a +1 on this. I have also installed to the root address (http://<pandoraserver>/index.php), and had no flash graphs after installation. This little patch fixed it.

Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes