Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Upgrading from 7.718 to 7.727 in Centos Pandora ISO.
(10-04-2018, 11:33 AM)alberto.sanchez Wrote:
(10-04-2018, 08:10 AM)saleh Wrote:
(10-03-2018, 12:07 PM)alberto.sanchez Wrote:
(10-03-2018, 07:14 AM)saleh Wrote:
(10-02-2018, 11:34 AM)alberto.sanchez Wrote: Good morning saleh,

There are 2 possible solutions to your problem:

1- Install Pandora 727 with the ISO, doing a previous backup of the different ".conf" that you can use after.
2- Try to log to the database with: user->root pass->pandora. If this makes you access to the database, you only have to  change that info in the .conf of the server anc config.php. Remember to start the services with this order:
  • Mysql
  • Httpd(apache)
  • Console
  • Pandora Server
  • Pandora Agent.
Best regards,


I can't log in using root in 727.

Let me back a little bit, first I had production server running 718, using Pandora Docs, I backed up everything, alongside the DB; like so:
mysqldump -u root -p pandora > backup_pandora_X.Y.sql
Note: notice using root to login.
on lap running 2 vms, first 718, i restored the DB to it and upgraded to 727, second vm; 727 i directly restored the DB to it.
in booth cases pandora server gives errors, furthermore, i changed DB username to root in both vm, still getting error, changes made in config.php and pandora_server.conf.
Note: how to stop and start the console??

Good morning saleh,

Sometimes the DB only creates the user wit "root" and no pass, please try it that way and tell us how did it go.

P.D: It was a failure telling you about the start and stop of the console, there is no actions like that. Sorry


on booth 718 and 727 and on fresh installed iso and the ones that has DB recovered, strange i guess its always: pandora,pandora for mysql login.

[[email protected] ~]# mysql -n root
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO
Good morning saleh,
mysql -n?¿? Have you tried with -u?¿
Do you have the same login credentials in the pandora_server.conf and the config.php of the console?
If not try to reset root pass of the DB.

i started fresh, new 718 iso vm, i add simple agent config just to have some data, backed up the db like so:
case one:
mysqldump -u root -p pandora > /home/backup-root-pandora
case two:
mysqldump -u pandora -p pandora > /home/backup-pandora-pandora

and on new 727 i tried to restore the backups to it, in both cases i failed, for the record this how i restore:
case one: 
stop all pandora services
mysql -u root -p pandora
use pandora
source /home/backup-root-pandora
start all pandora services
case two:
stop all pandora services
mysql -u pandora -p pandora 
use pandora
source /home/backup-pandora-pandora
start all pandora services

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes