Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
module in pandora_agent not "loaded"
Hello I've spent some time today to try fix this and nothing happens.
I'm trying to add a custom module to an agent config file, and I've already done something similar in other servers.

The module is this :

module_name JavaCheck
module_type generic_data
module_description Check for java errors
module_min 0
module_max 3
module_min_critical 1

Where is a python script who performs some regexing on an application logfile.
It works from commandline as expected, owned by root (same user of pandora), perms 755.
It returns 0 if no errors are matched, otherwise returns 1.
RC 2-3 are thrown in case the applog is misconfigured.

It is never uploaded to server even if the agent is in apprentice mode.
I tried to verify pandora_agent.log, but it shows nothing about this.
I tried to restart the agent in debug mode, and it generates an xml who NEVER CONTAINS the indicated module.
It just reports data from the first, default installed modules of the agent. nothing else.

This is weird cause in other machines new modules were imported right away.
Someone can help me ?


Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes