Pandora FMS community forums
wmicのインストール - Printable Version

+- Pandora FMS community forums (https://pandorafms.com/community-forums)
+-- Forum: Pandora FMS (https://pandorafms.com/community-forums/forum-3.html)
+--- Forum: 日本語フォーラム / Japanese forum (https://pandorafms.com/community-forums/forum-9.html)
+--- Thread: wmicのインストール (/thread-6740.html)



wmicのインストール - shin16884 - 10-30-2012

お世話になります。

PandoraFMS4.0.2 Serverを評価しようとインストールの準備を進めているのですが
必要なパッケージを導入していたところwmicだけインストールすることができません。

【環境】
 AmazonWebService Amazon Linux 64bit

【現象】
 下記リンクにある「wmic-4.0.0SVN-2.1.el5.centos.noarch.rpm」をインストールしようとすると
 「libsasl2.so.2 is needed by wmic-4.0.0SVN-2.1.noarch」というエラーになる。
 
http://sourceforge.net/projects/pandora/files/Tools%20and%20dependencies%20%28All%20versions%29/RPM%20CentOS%2C%20RHEL/

 しかし、libsasl2.so.2は/usr/lib64/に存在している。

【質問】
 wmicのrpmをインストールするにはどのようにすればよいのでしょうか。

ご回答、よろしくお願いします。


Re: wmicのインストール - junichi - 11-02-2012

独自に配布しているパッケージが 32bit OS 用のためだと思います。

独自配布のパッケージでなければダメというわけではないので、64bit OS 用にコンパイル
された rpm をインストールしてみてください。rpmfind で探すとでてくるようです。

http://rpmfind.net/linux/rpm2html/search.php?query=wmic

今すぐ試せる AmazonWebService Amazon Linux 64bit な環境が無いので
私にて動作確認したわけではありませんが、お試しください。



Re: wmicのインストール - shin16884 - 11-05-2012

ご連絡ありがとうございます。

教えていただいたURLからwmic-4.0.0tp4-0.x86_64.rpmをダウンロードして
インストールしたところ問題なくインストールでき、pandoraFMSのインストールも
実行することができました。

ご報告が遅くなりましたが、ありがとうございました。