Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with text in images built with GD
Hi all!
I have just installed the last stable version of Pandora 1.3 on my Fedora 7 system.
Everything works but I have problems with GD. I have installed GD and php-gd from the official Fedora repository. Images are built fine in the php page and render the effective status of systems, but no text is show as legend.
For example, going on the "Pandora agents > Tactical View" menu I can see the Tactical Indicator but under the red, black and blue triangles no text is shown.
What should I do?

Thank in advance for your help,
A good start would be going to any of the images where you don't see the text and clicking on "view image" (on your browser menu) and then take a look at the access_log and error_log of the apache.
Let us know what it shows
I have done what you have suggested but I am not able to write it in this post because of the user accounts restrictions of this forum.
Have you got an email which I can use?

Thanks a lot for your help,


P.S.: I am sorry because of the two discussions opened, but I did not know what was the right section.
Because of the problem written in the previous post, I have sent you the entry added to the access_log by the h t t p d server after the "View Image" action via pm.

The error_log instead does not show any entry as pandora_server.error and pandora_server.log.

Thanks for your help,

That's the access_log entry finally! - - [19/Oct/2007:12:47:08 +0200] " G E T / pandora_console / reporting / fgraph . php ? tipo=odo_tactic&value1=100&value2=100&value3=100 H T T P/1.1" 200 4602 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20070718 Fedora/ Firefox/"
I'm having the same problem. I am sure I installed all the correct dependencies but still no text in the images. Maybe something with font support?
Now I have just installed php* and perl* from the repository. Nothing... It is the only problem I have with Fedora. I have written a guide for the installation of Pandora on Fedora step by step too, but It is useless to share it with the world if I cannot solve this problem.
Could my step by step howto help with the diagnostic?
I'm having the problem on Ubuntu 7.04. I had it fixed on a previous installation of Pandora (1.3 beta) on another computer by installing a certain prerequisite I accidentally bumped onto but I forgot which one it was :oops:
It was a font_path problem.
I have studied the fgraph.php code concerning the odo_tactic graph building type.
This function loads the font from the path specified in the variable $config_fontpath wrongly specified in the config.php file. I have corrected it specifing the correct path (the absolute path is /var/www/html/pandora_console/include) and now it works!

I hope to have helped you too!

This is an access.log file . The problem should be in the error.log file or in the php error file (if configured).


Users browsing this thread: 1 Guest(s)

(c) 2006-2018 Artica Soluciones Tecnológicas. Contents of this wiki are under Create Common Attribution v3 licence. | |

Theme © MyBB Themes