Pandora FMS community forums

Full Version: Enviar correos desde Office365
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Estimados, acabamos de cambiar de plataforma de correo de Google Apps a Office365, el problema radica en que hemos dejado de recibir notificaciones por correo. He probado con distintas configuraciones pero no funciona nada. He revisado los log y solo da error. Tambien probé enviando correos por consola y llegan sin problema.

Me pueden ayudar a configurar los parámetros correctamente.

Como referencia utilizamos para otros sistemas internos (que ya estan funcionando correctamente) los datos de la siguiente página:
Hola jpegazo,

Las únicas opciones de configuración para utilizar un SMTP se encuentra en el fichero pandora_server.conf, aquí debes buscar los parámetros "mta" y serán los que habrá que modificar. Si pese a todo no logras que funcione, puedes optar por dejar el envío local de email (postfix/sendmail).

Un saludo,
Antonio.
Estimados revivo este tema para comentar que finalmente pude hacer funcionar el envío en Office365 desde la versión 6 SP5, pero luego de implementar la versión 7, la configuración no funciona. He probado con el relay de  Google y nada.

Revisando el log me arroja lo siguiente:

2017-04-03 00:18:52 SRV-PANDORAFMS [V1] [E] 'SRV-PANDORAFMS': Wide character in subroutine entry at /usr/lib/perl5/PandoraFMS/Sendmail.pm line 310.
2017-04-03 00:18:52 SRV-PANDORAFMS [V1] Pandora FMS Server 'SRV-PANDORAFMS' unhandled error.
2017-04-03 00:18:54 SRV-PANDORAFMS [V1] [E] 'SRV-PANDORAFMS': Wide character in subroutine entry at /usr/lib/perl5/PandoraFMS/Sendmail.pm line 310.
2017-04-03 00:18:54 SRV-PANDORAFMS [V1] Pandora FMS Server 'SRV-PANDORAFMS' unhandled error.
2017-04-03 00:18:54 SRV-PANDORAFMS [V1] Pandora FMS Server restarting () in 60 seconds.


No me manejo con la programación por lo que no se a qué se refiere con el error, espero me puedan ayudar

Saludos!
Hola jpegazo,

Has probado si el envío de correos con algún otro servidor SMTP te funciona correctamente? En nuestro entorno no disponemos de un office365 para poder replicar el entorno.

Un saludo,
Antonio.
He probado con Google (aspmx.l.google.com) y recibo el mismo error en el log

Tanto la configuración de Office365 como la de Google me funcionaban en 6 SP5 (solo que recibia los correos sin formato), pero ahora ni siquiera salen...
Hola jpegazo,

Con el postfix del sistema enviándolo contra localhost también te da problemas? Intentemos acotar lo máximo posible el entorno de fallo.

Un saludo,
Antonio.
probando con el comando sendmail [email protected] llega sin problema bajo root <[email protected]>

Que comando debería ocupar?

Cabe señalar que tengo instalado en SP7 desde la ISO publicada
Hola jpegazo,

Podrías probar a utilizar el envío de mails de alertas con el postfix local? Bastaría con que establecieses en el fichero pandora_server.conf este parámetro:

Code:
mta_address localhost

Y comentases todos los demás parámetros de mta.

En mi entorno de pruebas ha funcionado, pero así comprobamos si se trata de un problema aislado de tu instalación o efectivamente ocurre únicamente al utilizar servidores SMTP externos.

Un saludo,
Antonio.
Antonio haciendo lo que me dices, ocurre exactamente lo mismo...
Hola jpegazo,

Estoy comprobando el envío de correos contra localhost y me funciona correctamente.

Qué versión de consola y server tienes? Puedes mirar la versón de la consola en el footer de la página y la versión del server en la vista táctica. Las versiones que yo he empleado son las de la versión 7 oficial que se encuentra en sourceforge (https://sourceforge.net/projects/pandora...0NG/Final/),
consola: Pandora FMS v7.0NG - Build PC170324 - MR 0
server: 7.0NG (P) 170324

También puedes comprobarlo ejecutando en el terminal:
Code:
rpm -qa | grep pandora

Si no te funciona correctamente te recomendaría actualizar el paquete del servidor.

Un saludo,
Antonio.
Pages: 1 2