Pandora FMS community forums

Full Version: Falsos positivos con Agente Windows v3.2
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hola,

  Me está pasando una cosa muy curiosa con unos agentes en Windows.

Os pongo en antecedentes:

* Pandora server versión 3.2RC1
* Pandora Windows Agent v3.2

  Hay un  monitor del tipo "generic_proc" que controla la existencia de un proceso y que devuelve siempre un 1 si todo va Ok y un 0 si el proceso se ha parado. que se envía al monitor cada 300 segundos (5 minutos).

  Existen también una alerta asociada que nos envía un SMS + correo electrónico, en el caso de que el proceso se caiga.

  Pues bien, de vez en cuando bajo, no sabemos qué circunstancia, el servidor nos envía una alerta de servicio caido y, seguidamente (de manera inmediata), un mensaje de "recover" ¿?¿?¿?¿?¿?....

1.) ¿Cómo es posible, en cualquier caso, si se trata de una alerta verídica, me mande la alerta del recover antes de los 5 minutos que tiene el agente programado para contestar?

2.) Teniendo marcado el campo "Histórico de datos", sólo puedo visualizar una entrada que dice que el último valor se recibió hace "tantos" minutos ¿?¿?¿?¿?.... así, tampoco puedo puedo ver el histórico de valores.....

  Lo peor de todo, es que luego reviso la máquina y , realmente, no ha pasado nada....

  También he probado a poner los agentes en modo "debug" y, la verdad, es que siempre veo que el dato es correcto... ¿?¿?¿?


¿que está sucediendo?  ¿alguna idea de porqué tengo éstos falsos positivos?  ¿?¿?....

Curiosidades: Sólo me ha pasado con agentes windows que están en versiones 2003. Los que tengo en versiones 2000, las versiones más antiguas del agente y,  cualquiera de mis  agentes unix van divinamente...

:-?


 
Hola fredman,

Consejo: activa en tu pandora_server.conf la opción verbosity 10 para recibir información más completa y detallada en los logs del servidor sobre el proceso que sigue, a ver si te muestra alguna nueva pista de por donde andan los tiros.

También es recomendable que compruebes en tu pandora_agent.conf la configuración de ese módulo; si has definido un watchdog en dicho módulo, es probable que en realidad sí este pasando eso de que intermitentemente el proceso se detenga y reinicie automáticamente...

Se agradecería también que adjuntaras alguna información o captura de pantalla sobre la configuración de tu alerta. Wink

Saludos.



Hola,

  Ante todo, muchas gracias por tu atención, la verdad es que activé el nivel de traza a 10, pero el log no arrojaba ninguna luz.

  En cualquier caso, ya comprobé que el error eran los valores que me devuelven los agentes. Alguno de los monitores, vigilaban procesos de Windows a través de métodos Unix (ps -ef | grep proceso | wc -c, por ej.), pero esto parece que patina un poco en Windows (que raro, ¿verdad?).

  Bueno, por ahí todo arreglado utilizando el comando nativo "module_service".

  Sin embargo, el otro nodo (windows) que me manda falsos positvos, realiza un checkeo de un servicio web remoto y comprueba la recepción de una cadena concreta.

  (Lo mismo más de uno se rie con ésto)

  Estoy utilizando Lynx, desde el propio agente, para comprobar el sitio enlazado con un grep para comprobar la respuesta.
ej:

Code:
c:\Archiv~1\pandora_agent\util\lynx\lynx -connect_timeout=10000 -cfg=c:\Archiv~1\pandora_agent\util\lynx\lynx.cfg -lss=c:\Archiv~1\pandora_agent\util\lynx\lynx.lss -dump http://www.misitioweb.com/servicio?parametros |grep -c "La plataforma esta arrancada correctamente" & set ERRORLEVEL=0

  ¿Se os ocurre una manera más elegante de hacerlo?