Pandora FMS community forums

Full Version: Error Sending email to xxxx --> EXTERNAL MAIL
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Buenas,
estoy configurando el Pandora server 7.0 con un CentOS 7 y me da problemas el envio de correos, lo más curioso es que este es el segundo pandora que monto en el mismo entorno y anteriormente me funcionaba el envio de correos con los mismos datos de correo pero ahora no....o me dejo algo o no se... mi configuración del correo es la siguiente:


Code:
mta_address smtp.strato.com
mta_port 587
mta_user [email protected]
mta_pass xxxxxxx
mta_auth LOGIN
mta_from Pandora FMS <[email protected]>


En el pasado esta configuración me funciono, porque recibia correos, pero ahora....el correo ha de marcararse como SSL pero no esta la opción de poner un MTA_TYPE SSL por lo que no se como hacer para recibir correos.

En los logs unicamente aparece:


Code:
2018-12-13 16:40:00 ksrpandora.ksr.local [V1] [ERROR] Sending email to [email protected] with subject [PANDORA] Alert from agent KSRESXi01 on module Uptime


he de configurar el POSTFIX del propio centos para enviar los correos? gracias


saludos
(12-13-2018, 03:37 PM)gairhald Wrote: [ -> ]Buenas,
estoy configurando el Pandora server 7.0 con un CentOS 7 y me da problemas el envio de correos, lo más curioso es que este es el segundo pandora que monto en el mismo entorno y anteriormente me funcionaba el envio de correos con los mismos datos de correo pero ahora no....o me dejo algo o no se... mi configuración del correo es la siguiente:


Code:
mta_address smtp.strato.com
mta_port 587
mta_user [email protected]
mta_pass xxxxxxx
mta_auth LOGIN
mta_from Pandora FMS <[email protected]>


En el pasado esta configuración me funciono, porque recibia correos, pero ahora....el correo ha de marcararse como SSL pero no esta la opción de poner un MTA_TYPE SSL por lo que no se como hacer para recibir correos.

En los logs unicamente aparece:


Code:
2018-12-13 16:40:00 ksrpandora.ksr.local [V1] [ERROR] Sending email to [email protected] with subject [PANDORA] Alert from agent KSRESXi01 on module Uptime


he de configurar el POSTFIX del propio centos para enviar los correos? gracias


saludos

Buenos días gairhald,

En primer lugar tienes la versión desactualizada de Pandora FMS, pues nos encontramos en la versión 729 donde se ha mejorado, entre otras cosas, el envío de mails. Además, como bien indicas, si puedes mirar si el POSTFIX del otro servidor donde tienes montado Pandora tiene diferencias con el que acabas de montar.

Alberto
Si perdona, la versión de Pandora es la 7.28, y no puedo ver la otra configuración porque el anterior se elimino al corromperse los discos donde estaba, por eso no puedo copiar la configuración que si me iba, pero la verdad, no recuerdo haber configurado el postfix en el anterior :/
(12-14-2018, 02:21 PM)gairhald Wrote: [ -> ]Si perdona, la versión de Pandora es la 7.28, y no puedo ver la otra configuración porque el anterior se elimino al corromperse los discos donde estaba, por eso no puedo copiar la configuración que si me iba, pero la verdad, no recuerdo haber configurado el postfix en el anterior :/

Buenas tardes gairhald,

Prueba a intentar ponre como mta_address la IP en vez del DNS por si no resuelve correctamente la dirección. Intenta cambiar el Mta_port al 25 por defecto y prueba a realizarlo. En caso de que no funcione, prueba a modificar el parametro de "verbosity" del Pandora Server a 5 para ver con más detalle los mensajes del log, fuerza una alerta con mail para que salga el error y nos lo envias para poder estudiarlo.

Alberto
(12-17-2018, 03:04 PM)alberto.sanchez Wrote: [ -> ]
(12-14-2018, 02:21 PM)gairhald Wrote: [ -> ]Si perdona, la versión de Pandora es la 7.28, y no puedo ver la otra configuración porque el anterior se elimino al corromperse los discos donde estaba, por eso no puedo copiar la configuración que si me iba, pero la verdad, no recuerdo haber configurado el postfix en el anterior :/

Buenas tardes gairhald,

Prueba a intentar ponre como mta_address la IP en vez del DNS por si no resuelve correctamente la dirección. Intenta cambiar el Mta_port al 25 por defecto y prueba a realizarlo. En caso de que no funcione, prueba a modificar el parametro de "verbosity" del Pandora Server a 5 para ver con más detalle los mensajes del log, fuerza una alerta con mail para que salga el error y nos lo envias para poder estudiarlo.

Alberto

No puedo poner el puerto 25 porque las especificaciones de este servidor de correo con el 465 o el 587, y he probado los dos, y tambien poniendo la IP.

He cambiado la verbosity a 5 pero no da más info de lo del error...

si miro el log del mailog me sale esto


Code:
Dec 17 22:35:27 ksrpandora postfix/sendmail[10128]: fatal: parameter inet_interfaces: no local interface found for ::1
Dec 17 22:35:27 ksrpandora postfix[10171]: fatal: parameter inet_interfaces: no local interface found for ::1

no se si tendre que configurar algo en el postfix :/
(12-17-2018, 09:40 PM)gairhald Wrote: [ -> ]
(12-17-2018, 03:04 PM)alberto.sanchez Wrote: [ -> ]
(12-14-2018, 02:21 PM)gairhald Wrote: [ -> ]Si perdona, la versión de Pandora es la 7.28, y no puedo ver la otra configuración porque el anterior se elimino al corromperse los discos donde estaba, por eso no puedo copiar la configuración que si me iba, pero la verdad, no recuerdo haber configurado el postfix en el anterior :/

Buenas tardes gairhald,

Prueba a intentar ponre como mta_address la IP en vez del DNS por si no resuelve correctamente la dirección. Intenta cambiar el Mta_port al 25 por defecto y prueba a realizarlo. En caso de que no funcione, prueba a modificar el parametro de "verbosity" del Pandora Server a 5 para ver con más detalle los mensajes del log, fuerza una alerta con mail para que salga el error y nos lo envias para poder estudiarlo.

Alberto

No puedo poner el puerto 25 porque las especificaciones de este servidor de correo con el 465 o el 587, y he probado los dos, y tambien poniendo la IP.

He cambiado la verbosity a 5 pero no da más info de lo del error...

si miro el log del mailog me sale esto


Code:
Dec 17 22:35:27 ksrpandora postfix/sendmail[10128]: fatal: parameter inet_interfaces: no local interface found for ::1
Dec 17 22:35:27 ksrpandora postfix[10171]: fatal: parameter inet_interfaces: no local interface found for ::1

no se si tendre que configurar algo en el postfix :/

Good afternoon gairhald ,

Try to follow this steps to solve the postfix problem:

https://codinfox.github.io/dev/2015/04/0...not-start/

Alberto
(12-18-2018, 03:03 PM)alberto.sanchez Wrote: [ -> ]
(12-17-2018, 09:40 PM)gairhald Wrote: [ -> ]
(12-17-2018, 03:04 PM)alberto.sanchez Wrote: [ -> ]
(12-14-2018, 02:21 PM)gairhald Wrote: [ -> ]Si perdona, la versión de Pandora es la 7.28, y no puedo ver la otra configuración porque el anterior se elimino al corromperse los discos donde estaba, por eso no puedo copiar la configuración que si me iba, pero la verdad, no recuerdo haber configurado el postfix en el anterior :/

Buenas tardes gairhald,

Prueba a intentar ponre como mta_address la IP en vez del DNS por si no resuelve correctamente la dirección. Intenta cambiar el Mta_port al 25 por defecto y prueba a realizarlo. En caso de que no funcione, prueba a modificar el parametro de "verbosity" del Pandora Server a 5 para ver con más detalle los mensajes del log, fuerza una alerta con mail para que salga el error y nos lo envias para poder estudiarlo.

Alberto

No puedo poner el puerto 25 porque las especificaciones de este servidor de correo con el 465 o el 587, y he probado los dos, y tambien poniendo la IP.

He cambiado la verbosity a 5 pero no da más info de lo del error...

si miro el log del mailog me sale esto


Code:
Dec 17 22:35:27 ksrpandora postfix/sendmail[10128]: fatal: parameter inet_interfaces: no local interface found for ::1
Dec 17 22:35:27 ksrpandora postfix[10171]: fatal: parameter inet_interfaces: no local interface found for ::1

no se si tendre que configurar algo en el postfix :/

Good afternoon gairhald ,

Try to follow this steps to solve the postfix problem:

https://codinfox.github.io/dev/2015/04/0...not-start/

Alberto

Lo he cambiado pero sigue fallando, ya mirare a ver de configurar el postfix si es necesario, proque no se me ocurre nada más
Buen dia estimado gairhald, tengo problemas con el envio de email, leyendo tu post, mi consulta es en que version de PandoraFMS te funciono el envio de email ?