Pandora FMS community forums

Full Version: error al ejecutar el 14.sql
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hola:

He actualizado de la version p18  a la p21, y al ejecutar el scrip de migracion me he encontrado con el siguiente error:

 cat 14.sql | mysql -u root -p pandora                        
Enter password:
ERROR 1064 (42000) at line 50: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '0' at line 1


Al ejecutarlo de nuevo

cat 14.sql | mysql -u root -p pandora
Enter password:
ERROR 1060 (42S21) at line 40: Duplicate column name 'update_secondary_groups

Entiendo que lo ha hecho bien, pero el error me mosquea un poco.

Un saludo.
(04-24-2018, 09:28 AM)aitor Wrote: [ -> ]Hola:

He actualizado de la version p18  a la p21, y al ejecutar el scrip de migracion me he encontrado con el siguiente error:

 cat 14.sql | mysql -u root -p pandora                        
Enter password:
ERROR 1064 (42000) at line 50: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '0' at line 1


Al ejecutarlo de nuevo

cat 14.sql | mysql -u root -p pandora
Enter password:
ERROR 1060 (42S21) at line 40: Duplicate column name 'update_secondary_groups

Entiendo que lo ha hecho bien, pero el error me mosquea un poco.

Un saludo.

Hola aitor,

Según entiendo con mi humilde conocimiento en mysql, en el segundo error se esta tratando de realizar un Alter Table adicionando el campo 'update_secondary_groups' el cual ya existe.

El primer error corresponde a que el comando PREPARE pr_oum721 FROM @st_oum721; de la linea 50 no es reconocido por la version actual de mysql.

Espero que esto te de una luz para solucionar tu problema.