Pandora FMS community forums

Full Version: Error actualizando consola
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hola,

Pandora me indica que hay una nueva versión de la consola para instalar, pero al intentar instalarla se produce un error.

¿Que puedo hacer para conseguir actualizar la consola?

Gracias.
Buenas tardes serco:

Para poder ayudarte y asi profundizar más en el problema, necesito saber:

-SO qué estás utilizando
-Versión de Pandora que has instalado

Un saludo.
Buenas,

pandora esta instalado en un centos 6 (la imagen vmware preparada que tenéis) y estas son las versiones:

pandorafms_server-7.0NG-1.noarch
pandorafms_console-7.0NG-1.noarch
pandorafms_agent_unix-7.0NG-1.noarch

Pandora FMS v7.0NG - Build PC170324 - MR 1

Este Pandora se instalo hara un par de años y hasta ahora he actualizado siempre sin ningún problema pero al querer actualizar de la versión 180205 a la 180219 es cuando me ha surgido el fallo (como se ve en la imagen).
Buenos días serco:


Prueba a descargarte los paquetes de la última versión y actualizarlos. Pero antes de eso, te recomiendo hacer un backup de la base de datos y una copia de seguridad del fichero config.php de Apache

Ruta del config.php : /var/www/html/pandora_console/include/config.php

Después de realizar estos pasos, coméntame  si todo ha salido correcto.

Un saludo,

fraguas.
ok, ¿alguna guía de como hacer la descarga y actualización manual?

Gracias.
Buenas tarde serco:

Te adjunto el link con los pasos para actualizar.

 https://wiki.pandorafms.com/index.php?title=Pandora:Documentation_es:Actualizacion

Un saludo,

fraguas.
Buenos días,

he actualizado manualmente y si que veo aplicadas las nuevas versiones:

pandorafms_console-7.0NG.719-1.noarch
pandorafms_server-7.0NG.719-1.noarch
pandorafms_agent_unix-7.0NG.719-1.noarch

El problema es que desde la web sigue indicándome que hay una nueva versión y sigue dando error al instalarla. (imagen adjunta)

Y en el pie de página si que veo que ha cambiado de esto:

Pandora FMS v7.0NG - Build PC170324 - MR 1
  (ahora veo que antes no se correspondía con la versión que indicaba la consola)

a esto:
Pandora FMS v7.0NG.719 - Build 180205 - MR 1


El paquete de consola que he instalado es el mas nuevo que he visto en http://firefly.artica.es/centos7/ ,  no se si existe uno mas nuevo en algún otro sitio.

pandorafms_console-7.0NG.719-1.noarch.rpm    21-Feb-2018 17:03     27M   (no se indica la Build)
Buenas tardes serco: 

En sí ya se te actualizó la consola, pero por la web no te va a dejar ya que el campo de la bbdd en si no se ha actualizado.

Mi consejo es que aunque aparezca en la web, descartes esta opción ya que la actualizaste manualmente y no te dio ningún tipo de problema.

Un cordial saludo,
fraguas.
Ok ¿crees que la próxima actualización se aplicará correctamente desde el Update Manager?


Y otra pregunta ¿sería posible actualizar ese campo de la bbdd manualmente para que todo se muestre correctamente?

Un saludo y gracias por la ayuda.
Buenos días serco:

Estamos trabajando para qué en la proxima versión de UM vaya todo perfecto.

Respecto a lo de la BBDD, tendrías que cambiar el campo correspondiente  a la versión en la tabla "tconfig" , y el campo a modificar sería "lastupdate" . Tendrías que cambiar 180205 por 180219. 

Espero poder haberte ayudado a solucionar tu problema.

Un cordial saludo,

fraguas.
Pages: 1 2