Pandora FMS community forums

Full Version: [Solved] flash graph is not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Nothing happens, the problem remains.

Thanks for your help.

This is my screen,
My case SOLVED.

You were wright. I compared the actual version with the old one (2.1) and I discovered some difference in the configuration of the file ./include/config.php.

The configuration which does work is:

<?php
// Begin of automatic config file
$config["dbname"]="pandora";                    // MySQL DataBase name
$config["dbuser"]="root";                      // DB User
$config["dbpass"]="pandora";                    // DB Password
$config["dbhost"]="localhost";                  // DB Host
$config["homedir"]="/var/www/pandora_console";          // Config homedir
$config["homeurl"]="/pandora_console";                  // Base URL
// End of automatic config file

I changed it, and all the graphics are working.
As I see in the picture you have sent, you have your url in /pandora_console, so you should have in your config file:

$config["homeurl"]="/pandora_console";

Anyway, if you take a look at the source code of the HTML page in the graph page, and search for FusionCharts, what do you see?

By the way, I'm from Salamanca :-D


(01-19-2010, 08:22 AM)nachocharro link Wrote: [ -> ]Nothing happens, the problem remains.

Thanks for your help.

This is my screen,
You're right in the two things,

FusionChart is referred to pandora_console

<script language="JavaScript" src="/pandora_console/include/FusionCharts/FusionCharts.js"></script>

and I'm from Salamanca too.

All is working now, better than ever.
Quote:var myChart = new FusionCharts("' .    $pre_url .  '/include/FusionCharts/FCF_MSArea2D.swf",

fixed our problem.

thanks!
(01-18-2010, 05:50 PM)raul link Wrote: [ -> ]Mmm, I think it's a bug. It should be solved in one commit.

Let's try to solve it:

Change the code in the /include/functions_fsgraph.php file, line 195, from:

[sup]var myChart = new FusionCharts("' .   $config["homeurl"] .  '/include/FusionCharts/FCF_MSArea2D.swf",[/sup]

to

[sup]var myChart = new FusionCharts("' .     $pre_url .  '/include/FusionCharts/FCF_MSArea2D.swf", [/sup]

Please, change, and try again.

Thanks.

Raul

Just wanted to throw in a +1 on this. I have also installed to the root address (http://<pandoraserver>/index.php), and had no flash graphs after installation. This little patch fixed it.
Pages: 1 2